Support » Plugin: Collapse-O-Matic » Highlander acting up

  • Resolved pandem

    (@pandem)


    I am using a roll-your-own approach to toggle between some text and a photo slider. The text is visible initially and everything is working OK, except for a stupid detail: if, having the slider on display, the page is reloaded, both text and slider are shown. The logical way to avoid this seems to be using highlander grouping, but then the slider is never shown (it jumps out shortly on clicking the link and then stays closed). Am I overlooking missing?
    The site is not visible at the moment, but I can paste here the code I’m using in case you need it.
    Thanks, this plugin is fantastic!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Baden

    (@baden03)

    Please explain more about:

    if, having the slider on display, the page is reloaded, both text and slider are shown

    Your description is a bit confusing, and without a link it’s hard to understand what exactly your issue is.

    I will try to describe it more graphically. This is what I have on my page:
    ——-
    Some text visible on page landing (id=intro). It will be hidden when clicking “View images” link.
    View images (link)

    Images hidden on page landing (id=slider). They are shown when clicking “View images” link and will be hidden when clicking “View text” link.
    View text (link)
    ——-
    When images are visible and text hidden, if you reload the page (now with anchor #slider appended to slug), the text reappears over the images, but it should remain hidden. I tried to use highlander grouping to this effect, but it does not seem to work, as told on my previous post.

    I created a test user for you in case you need to view it in action. You can login here with user “test”, pwd “test”, and you will be redirected to a page using Collapse-O-Matic. Please click on “Ver fotos” to show the slider and then reload the page to see what I am talking about.

    Thank you for finding some time to consider this issue!

    • This reply was modified 2 years, 8 months ago by  pandem.
    • This reply was modified 2 years, 8 months ago by  pandem.
    Plugin Author Baden

    (@baden03)

    Thank you, the link helped.
    you might want to remove that test account now.

    The issue is that you are using both a span element ‘span’ for the collapse/expand and this is wrapping an anchor element ‘a’.

    There is no reason for the anchors, as the ID can be used as an anchor when navigating to the page using url anchors.

    However, if you MUST use anchor tags, please check out the documentation on the expandanchor class. Here is a demo:
    http://spacedonkey.de/716/collapse-o-matic-id-tag-in-link/

    It took me a while, but I finally saw what you meant. I was overdoing it! After some clean-up, less coffee and further reading of documentation, everything is working as expected. Thank you for your help!

    Plugin Author Baden

    (@baden03)

    glad to hear you got it working!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Highlander acting up’ is closed to new replies.