Support » Plugin: ACF-VC Integrator » Hide Empty Labels

  • Resolved dc23

    (@datenchef)


    Hi! I am displaying some values of a property / house like land area, living m2, acreage, price and so on which is working fine. Except when a value is empty, eg there is no acreage then the label still shows. I am using “Show Labels” checked because i need the info which is meaning of the value. Any chance to chance this? So if no value also no label. I was also looking in the code for a hack but somehow it didnt went out right. Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    Hi @datenchef,
    Sorry for the slow response

    There should be an option under “Show Labels” called “Yes and hide if no result” that should do what you’re asking for.

    If you are using the latest version, you should be able to set this option as an default under Settings-> ACF-VC Integrator.
    If you still experience problems with it just write again.

    Best regards
    Frederik

    dc23

    (@datenchef)

    Thank you for reply, @frederik-rosendahl-kaa. I am grateful for your time, work and support. What a pitty, i didnt see that options. Sometimes… Alright i set default to “Show label Yes and hide if no result”.

    What i would expect to happen (and what i actually want to achieve) if there is a value, then “Show label: $value”. If theres is no value “hide that line with label”.

    In my grid template i unchecked “show label” because i thought its now default. So what happens, that line with a empty value is hidden, perfect. But if there is a value, the value is printed alone without label. If i keep it the checked, the label is still shown if there is a empty value.

    Can you get a clue?

    I user the latest version of your plugin 1.4.0 and Page Builder 5.5.5.

    Thanks!

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    It sounds strange, I have just done some quick tests with me and seem to work.

    After you’ve set them to default on the elements. Have you then checked how the settings are set under the settings page for the plugin (Settings -> ACF-VC Integrator).
    By default, the Default setting is set to the No for “show label”.

    Alternatively, you have the option to send a link to the screenshort of the elements settings and plugin settings.

    Best regards
    Frederik

    dc23

    (@datenchef)

    > After you’ve set them to default on the elements.

    How do i do that?

    I made some tests in a different wordpress installation without my custom post type, just normal posts. Please see my screenshots here https://imgur.com/a/A6agkYq

    What i want to achieve is that post “Test without number” has a hidden Number line, to say that “Number:” hides if there is no value.

    In my client site there will be 5,6 lines with values and not every object has all fields filled, eg a garage…

    If i had in pic 3 show label unchecked, then the value is printed alone without label.

    Many thanks.

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    Hi again @datenchef,

    I have quickly taken a look at the pictures you have sent me and see that you are not using the ACF-VC elememte.
    The element is called ACF-VC Integrator and the icon is the smame as plugin icon.

    Hope it solves your problem.

    Best regards
    Frederik

    dc23

    (@datenchef)

    You are absolutely right, Frederik. Outch. If i go to a page add element, there i find your element with the nice icon but i am editing in the grid builder and dont have the element icon which i find on pages add element dialog, please see https://imgur.com/a/WB0UJXw – is that ok? In other words, your integrator element doenst work on grids? Thanks.

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    You’re quite right, to be honest I’ve forgotten everything about the grid builder.
    It was planned that it would be implamed, but something happened to the company I worked for and I forgot all about it.
    But I get started right away so I can get it supported as soon as possible.

    Thank you for making me aware of that.

    dc23

    (@datenchef)

    Alright, than you very much – its often this simple, haha.

    chisomosteve

    (@chisomosteve)

    Hi Frederik,
    I’d also be very interested in getting ACF-VC Integrator working in the Grid Builder – I want to output a custom field on the grid but hide the label if the field is empty.

    I can’t find any simple way to achieve this!

    Thanks so much for your work on this plugin.

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    Hi @datenchef and @chisomosteve

    I’ve just got a version ready where grid builder support has been added.
    However, I would hear before I publishing the version if I could get you to test it and maybe give some feedback.
    If you wanted to test it, you can use this link to download it https://www.dropbox.com/sh/b4yn5hhfxsbb1qn/AACJ2ruyUWMZUC_ISNSmOGnka?dl=0

    Do not worry, even if you do not test it, I expect it to be ready for release next week, maybe next Friday.

    Best regards
    Frederik

    dc23

    (@datenchef)

    Hi Frederik,

    thank you very much, that version working fine in pages and grid! Perfect. What even would be more epic if you could include the field name to this

    https://imgur.com/a/4FlxDfG

    So you can see which fields are used and thats really usefull if you have a plenty. Should i leave your test plugin activated? I would now kick my wrong acf fields and use yours in the grid.

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    Hi @datenchef,
    Thank you for testing the version, Glad to hear that it works perfectly.

    I’ve been working on it for some time now trying to show the name of the field, to create a better viewe.
    Unfortunately I have not gotten it to work yet, But working on it.

    Yes, you should be able to let the test plugin be installed, as I expect to publish a version 1.5 by this Sunday if everything goes as it should.
    And then you should be asked to get it updated.

    Plugin Author Frederik Rosendahl-Kaa

    (@frederik-rosendahl-kaa)

    Hi @datenchef and @chisomosteve

    I just wanted to inform you that I have now released a version 1.5.0 where I have been added support for grid builder.
    And I’ve got it done so it’s now possible to display the field name on the acf-vc integrator element so you have a better overview.
    I have done so that the field name is now displayed on the acf-vc integrator element, to get this part to work on fields that are created, all you have to do is press edit and then save the element and then the name would appear

    dc23

    (@datenchef)

    Thank you very much, Frederik. It works like a charm. Great work!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Hide Empty Labels’ is closed to new replies.