Support » Plugin: Quick Cache (Speed Without Compromise) » GZIP not working

  • Resolved Wonderful Wanderings

    (@wonderful-wanderings)


    Hi,

    Yesterday I copied the code for GZIP compression and pasted it in my .htaccess file. Somewhat later I run some website speed tests and each test gave me the recommendation to enable GZIP compression, so I’m guessing it’s not working.

    Is there any way I can find out what’s missing?

    Thanks

    https://wordpress.org/plugins/quick-cache/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Raam Dev

    (@raamdev)

    Hello,

    That’s hard to say. It really depends what the site you used for testing is actually looking for. Could you provide the site you used for testing and your site URL so that I can run the test myself?

    Sure: http://wonderfulwanderings.com is my site’s url and I used google’s speed test as well as quicksprout’s speed test

    Plugin Author Raam Dev

    (@raamdev)

    Hello,

    As far as I can tell, you don’t have GZIP compression enabled, which tells me there might be a problem on the web server (does your server have the mod_deflate Apache extension?).

    You should contact your web host and ask them why GZIP compression might not be working.

    That’s strange. I’d just replied here and the comment seems go.

    So, I’ve checked with my host and apparently I had to enable mod_deflate or something like that.
    I did that and they said it should be working now…

    Plugin Author Raam Dev

    (@raamdev)

    Yes, I just checked your PageSpeed results and the GZIP sections shows that the only GZIP content that is not being compressed are the external URLs (which might not be compressed, as they’re coming from a different server–it’s up to the remote server to serve them compressed). That tells me that GZIP compression is working as expected on your site. 🙂

    Thanks for checking!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘GZIP not working’ is closed to new replies.