Support » Fixing WordPress » Gutenberg broken after WP 5.9 update

  • Hey,

    I am no longer able to add/edit posts after updating to WP 5.9 – only white screen is shown. I tried “Disable Gutenberg” plug-in, and it allowed me to edit with the classic editor. Then I tried to see what’s wrong – the page source for the white screen contained full html document, and the console output is on the screenshot at imgdb.com

    • This topic was modified 3 months, 4 weeks ago by xs256.
Viewing 15 replies - 1 through 15 (of 23 total)
  • Try clearing all your caches? Plugin, server, browser.

    Same problem with me. When creating a new article, a white screen appears in the editor and three options are available: restore, etc.
    The article automatically saves in the sketches and can be further edited, but the white screen pops up notoriously.
    I have cleared all possible caches.
    At the moment I went back to the previous version of WordPress, because it was impossible to work normally.

    • This reply was modified 3 months, 4 weeks ago by kubick.
    Thread Starter xs256

    (@xs256)

    Gutenberg now works for me, but I am not sure, what caused the fix, because I performed two actions:
    1. I saw a fresh update for Rank Math plug-in and installed it.
    2. At the same time in another tab I was checking the browser console for Javascript error messages, and AFTER the plug-in update I cleared the console output and refreshed the “white page”.
    Then Gutenberg started working…

    Same for me, after updating to 5.9 I got white screen when trying to edit or create post or page.

    Hi,

    same here in https://skveleknihy.sk/. if I try to add/edit new article, Gutenberg is not loaded (white screen). There was two errors in Chrome console, i catch only first one before downgrade:

    react-dom.min.js:141 TypeError: l.styles.forEach is not a function

    I downgraded WordPress back to 5.8.3 and everything is ok now. But could you look on it? I dont want to stay on version 5.8.3.

    Thanks,
    Peter

    Hello all,

    We have released an update of Rank Math & Instant Indexing API, please update everything to the latest version after taking a backup and see if that helps.

    Thank you.

    I am experiencing the same problem after 5.9.

    TypeError: l.styles.forEach is not a function
        at edit-post.min.js:7:93641
        at Object.useMemo (react-dom.min.js:220:462)
        at c.useMemo (react.min.js:30:236)
        at zt (edit-post.min.js:7:93610)
        at Le (react-dom.min.js:100:3)
        at Pj (react-dom.min.js:231:183)
        at di (react-dom.min.js:168:305)
        at Nj (react-dom.min.js:168:236)
        at sc (react-dom.min.js:168:96)
        at gf (react-dom.min.js:162:109)
    Ye @ react-dom.min.js?ver=17.0.1:141
    

    Bro here the same! 5.9 Update killed my Gutenberg Editor. With Wite Screen

    How you downgraded to 5.8.3?? i have Updraft and secured many Backups, but when i recover to an “OLD” Version its still 5.9 but with The Posts of the 5.8.3 Time…

    With Error Code Failed to load resource: the server responded with a status of 509 ()

    • This reply was modified 3 months, 3 weeks ago by zyrox78.

    Same, 5.9 has killed my ability to edit.
    "react-dom.min.js?ver=17.0.1:141 TypeError: l.styles.forEach is not a function"

    • This reply was modified 3 months, 3 weeks ago by thomasparkes.

    Same here! Any clues for this?

    We have the same problem, after disabling ACF Pro page is loaded again.
    But with ACF we create custom blocks, so for now we downgrade back to 5.8.3.

    We have the same problem.
    I downgraded WordPress back to 5.8.3 and ok now.

    Just wanted to chime in that I’m also having the issue and can’t identify why. I’m also using WordPress.com for hosting, so I can’t downgrade back to 5.8.3

    Same problem here.

    Disabling all plugins and clearing caches did not work.

    We don’t have the Rank Math & Instant Indexing API installed.

    PLEASE LOOK INTO THIS.

    Uncaught TypeError: l.styles.forEach is not a function
        at edit-post.min.js:7:93641
        at Object.useMemo (react-dom.min.js:220:462)
        at c.useMemo (react.min.js:30:236)
        at zt (edit-post.min.js:7:93610)
        at Le (react-dom.min.js:100:3)
        at Pj (react-dom.min.js:231:183)
        at di (react-dom.min.js:168:305)
        at Nj (react-dom.min.js:168:236)
        at sc (react-dom.min.js:168:96)
        at gf (react-dom.min.js:162:109)
    
    /wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1
    • This reply was modified 3 months, 2 weeks ago by terrapop.

    Hi!

    So for some reason, we had this in our theme:

    
    add_filter('block_editor_settings_all', function ($settings) {
        unset($settings['styles'][0]);
        return $settings;
    });
    

    Could be something to check in your themes, I hope I can help someone at least.

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.