Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » Gravity Forms Submission Cookie Not Applied

  • Resolved jmessy919

    (@jmessy919)


    Hello,

    I am using the latest version of Gravity Forms with the latest version of Popup Maker.

    I have selected to hide the popup using a sitewide Gravity Forms Submission cookie. When the form is submitted, it redirects to the page I set in the form’s settings and then the popup shows again.

    I have tried to remedy this with two cookies having identical names and settings, except one is a session cookie and one is not – however, this did not fix the issue.

    It’s interesting, because closing the popup manually adds the proper cookie which prevents repeat display – it seems the problem lies within the communication between Gravity Forms & Popup Maker.

    Any ideas? Thanks!

    – Jesse

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • In Addendum:

    Please note the form appears in a popup after 3000ms, and when dismissed it adds a cookie named “questionnaire-closed”.

    Regards,

    Jesse

    Quick Update:

    I have gotten the desired cookie to be activated using the following: https://wordpress.stackexchange.com/questions/235839/unset-a-cookie-on-successful-gravity-forms-form-submission.

    However, the popup ignores this cookie even though it is setup within the popup to stop displaying the popup for 1 session/1 month.

    I am thoroughly confused.

    Jesse

    Closing this ticket.

    Here’s what happened:

    I didn’t set the delay trigger to also be disabled by the submission cookie, just the dismissal cookie. One I set this to check for both, it functions as desired.

    For those wondering why the form redirect confirmation action is not setting the cookie, it’s something to do with how Gravity Forms works. There is a workaround, and that is to disable the Gravity Forms redirect and create your own like so:

    <script>setTimeout(function () { window.location = "redirect url here"; }, 300 );</script>

    OR

    Use the link in my previous post to set the cookie yourself.

    Hope this helps if someone else finds themselves in a similar boat.

    Jesse

    Plugin Author danieliser

    (@danieliser)

    @jmessy919 – Glad you got it all worked out :).

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.