Support » Plugins and Hacks » WordPress Zero Spam » Gravity Forms 2.1.1 FAIL

  • Resolved plymouthdesign

    (@plymouthdesign)


    All forms on one site we manage just died with the vague warning “There was a problem processing your submission.”

    GF logging showed no issues.

    Deactivating this plugin solved the matter.

Viewing 8 replies - 1 through 8 (of 8 total)
  • thinkel6

    (@thinkel6)


    I have the same problem. Had to deactivate WordPress Zero Spam to resolve gravity form “problem procession your submission”

    Now the spam is rolling in, any plan to fix this conflict?

    plymouthdesign

    (@plymouthdesign)


    I would recommend enabling the “honeypot” feature in Gravity Forms – it is an option at the individual form level. This should solve the problem at least for form submissions.

    Ross Wintle

    (@magicroundabout)


    Just wanted to report that I’m also having this issue on WordPress 4.7 with Gravity Forms 2.1.1 and WordPress Zero Spam 3.0.4.

    I am also having issues with 2.1.1 Gravity Forms. I’ve updated WordPress Zero Spam to the latest version. If you uncheck the GF support option, it works.

    My Site Info:

    • Host: WPEngine
    • PHP Version 5.5.9-1ubuntu4.20
    • MySQL Version 5.6.32
    • WordPress Version 4.7
    • Gravity Forms Version 2.1.1

    Page To Test.
    https://russellenvy.com/submit-band-name/

    UPDATE: The issue is with (Line 24) on https://github.com/bmarshall511/wordpress-zero-spam/blob/master/src/js/zerospam.js.

    Line #24 src code:
    forms += ", #gform_2";

    When I viewed the page source of my form (Link above in the previous comment), My form is: #gform_1 or #gform_3

    I do not have a form with an ID of 2.

    In my development environment, I changed line 24 to:

    forms += ", #gform_1";

    Now, my form with an Id of 1 works.

    My other form, ID of 3, still breaks. I think you need to set this up to work with another gravity forms ID or set it to look for any ID. something like #gform_*. Or pass an array and hardcode it from #gform_1 to #gform_200

    Plugin Author bmarshall511

    (@bmarshall511)


    Thanks to @geekstreetwp, this should be fix in the latest version: https://github.com/bmarshall511/wordpress-zero-spam/pull/140

    Happy To help. We install this on a lot of our maintainn.com client sites. it’s in our best interest to help the community!

    Ross Wintle

    (@magicroundabout)


    Just want to thank you guys for fixing this so quickly. I’d probably have been able to do it myself but circumstances prevented me. Great work!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.