Support » Plugin: WP Mail SMTP by WPForms » Google Api Problem

  • Resolved hr-automation

    (@hr-automation)


    Dear Support-Team!

    After i installed the latest Version 1.3.0 (1.3.1) i am running into problems with the Updraft Plus Plugin:

    0019.001 (0) PHP Fatal error (TypeError) has occurred. Error Message: Argument 1 passed to Google_Client::__construct() must be of the type array, object given, called in /var/www/virtual/htdocs/wp-content/plugins/updraftplus/methods/googledrive.php on line 689 (Code: 0, line 92 in /var/www/virtual/htdocs/wp-content/plugins/wp-mail-smtp/vendor/google/apiclient/src/Google/Client.php)
    0019.005 (0) An error condition has occurred for the first time during this job

    Please can you fix the incompatible version of the Google toolkit? -> Regarding this topic: https://wordpress.org/support/topic/google-drive-backup-error/

    Thank you very much for your time!

    Best regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jared Atchison

    (@jaredatch)

    First, I really apologize for the trouble.

    In 1.3.0 we updated our PHP Google API library. A side effect of that, in some cases, it causes a conflict with plugins which are using older versions of the Google API library.

    We’re working on a plan to resolve the problem! I don’t have an exact ETA, but we should have it fixed next week.

    If you’re affected by this, you can either temporarily deactivate WP Mail SMTP until next week when we address this issue, or if things worked for you prior to 1.3, you can downgrade.

    To downgrade:
    – On the WP Mail SMTP plugin page, go to Advanced (https://cl.ly/43321D403Z3v)
    – Look for the “PREVIOUS VERSIONS” at the bottom of the page.
    – Select 1.2.5 and it will download the previous version.

    Again, sorry about this. We’ll have a fix out as soon as we can 🙂

    I said it was Google API library problem from day 1 and you said it had nothing to do with it, and I should be ignored.

    Then I posted the logs, showing your plugin conflicting with others. Now you admit i’m right.

    Why not just put back the old Google API library , how it was, from the old version. And then give us an option, in the settings, to use the new version of Google API library .

    Plugin Author Jared Atchison

    (@jaredatch)

    We never said there was not an issue with the Google API.

    The issues that the original posters were describing in the other threads, which you decided to jump in on, were not – in any way shape or form – related to the Google API. I want to be clear about that. All those issues have since been resolved.

    So to summarize: yes, you are correct, there is an issue in some cases with the Google API. However, you are causing confusion by posting in other threads that were created to report completely unrelated issues.

    The previous implementation of the Google API library causes many various issues for users using the Gmail mailer. The update we did resolved most of these issues, but unfortunately the unintended side effect of that conflicts with other plugins that are using older versions of the API. Either way there are issues. We’re not going back, though. Instead next week we’ll figure out how to get around the issue and release an update that puts all this behind us.

    In the mean time, you can downgrade as mentioned in the steps above, if you are affected by this.

    Sorry for jumping in. According to UpdraftPlus’ developer:

    UpdraftPlus is trying to run an operation, and so needs to load the version it expects; the other plugin has already loaded one, but shouldn’t have, because the call was to UpdraftPlus, not to it. Can you raise a support ticket with them?

    So here I am… 🙂

    The link to the original thread: https://wordpress.org/support/topic/conflict-with-wp-mail-smtp/

    • This reply was modified 2 years, 8 months ago by wpkiller.
    Plugin Author Slava Abakumov

    (@slaffik)

    Please read this thread: https://wordpress.org/support/topic/latest-version-cause-guzzlehttp-issue-with-backup-buddy/

    In short – seems to be fixed, will be released tomorrow.

    Hi,

    For days, I couldn’t backup my sites on my drive due to that! I don’t use Google with your plugin (Could not it be disabled in that case?).
    This is a major issue that should have immediately needed a communication or a downgrade (notification in admin dashboard). I had to pay OneDrive to have my backup + all the time spent to understand what was happening.
    Thanks to another plugin developer, I read that thread and downgraded to 1.2.5 to make my other plugins work.

    Hi,

    I have also wasted hours on this, thinking there was something wrong with my Google Drive when used in conjunction with UpdraftPlus. My server ran out of space with the multitude of failed backup files not getting pushed to Google Drive and then deleted, so basically a string of chaos in the wake of this problem.

    The whole downgrade idea is just as much work as switching to Easy WP SMTP, which I tried on one site, and that cures the problem. The question now, is how long we have to wait for a fix, or should I just bite the bullet and switch the other 60+ sites immediately to re-establish my backup integrity.

    Is the promised fix for tomorrow also a fix for UpdraftPlus?

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Google Api Problem’ is closed to new replies.