Support » Plugin: Simple Calendar - Google Calendar Plugin » Google API Error

  • Resolved melshimber

    (@melshimber)


    Hiya

    I am using the simple calendar and have created a couple of google api codes. Everytime I try to save the api code into the tools it gives me a ‘settings saved’ confirmation. However, when I travel to the calendar it gives me the error.

    Google calendar results will not show up until you create and save a Google API key.

    Here is a link to my calendar – http://adapsuk.org/wordpress/calendar/adaps-events/

    Any suggestions?

    I have run through the google API set up a couple of times and activated the google api in the developer console.

    M

    ### WordPress Installation ###

    Site Name: ADAPS
    Home URL: http://adapsuk.org/wordpress
    Site URL: http://adapsuk.org/wordpress
    Version: 4.7.2
    Locale: en_GB
    Timezone: Europe/London
    Multisite: No
    Permalinks: /%year%/%monthnum%/%day%/%postname%/
    WP Memory Limit: 40 MB
    WP Debug Mode: No
    Script Debug: No

    ### Active Theme ###

    Theme: Pinnacle – 1.4.6
    Child Theme: No
    Parent Theme: –

    ### Active Plugins ###

    Kadence Toolkit: 3.8
    Simple Calendar: 3.1.9
    Cryout Serious Slider: 0.6
    Enhanced Media Library: 2.4.4
    Force Regenerate Thumbnails: 2.0.6

    ### Server Environment ###

    Web Server: Apache
    PHP Version: 7.1.1
    MySQL Version: 5.5.54-0+deb7u2-log
    Server Timezone: UTC
    Display Errors: Yes
    Memory Limit: 256M
    Upload Max Filesize: 64M
    Post Max Size: 64M
    Max Execution Time: 50000
    Max Input Vars: 5000
    fsockopen: Yes
    cURL: 7.38.0
    OpenSSL/1.0.1t
    SOAP: Yes
    SUHOSIN: No
    WP Remote POST: Yes
    WP Remote GET: Yes

Viewing 8 replies - 1 through 8 (of 8 total)
  • Exactly the same with me (same WP Version, same PHP Version etc., only: Theme: Impreza, but that should not be the problem)!

    I had the same Problem. Solution in my case:
    – logout from any (!) google account (make shure you are logged out – thats crucial)
    – Login to the google account where your calender is located
    – navigate to the google API console (e.g. over the link of simple calendar admin tab)
    – deactivate calendar APP
    – delete all API Keys
    – activate calendar app again
    – create fresh API Key
    – Input in simple calendar
    and than it should word (at least it did in my case).

    I have tried that but I am still having issues, for some reason the API key just won’t save in the folder. I am assuming that the key should be displayed after it has been ‘added’ to the website.

    I do have another API key active as part of the theme, I have tried to use that key and activate the calendar on that project in the developer console but still no luck.

    At this point I am thinking of trying alternatives. Shame really, the maps API works perfectly.

    It doesn’t work. Why is there no official reply to our problem?

    Plugin Contributor Nick Young

    (@nickyoung87)

    If you all have the same server settings (or at least the PHP version) then it is an issue with PHP 7.1. There were some plugin breaking changes introduced in PHP 7.1 and we have not gotten that all taken care of yet. So the way to fix this currently would be to run PHP 7.0.x.

    It doesn’t work. Why is there no official reply to our problem?

    Please remember this is a free plugin with free support. We do our best to answer everyone as quick as we can, but we do have full-time jobs we have to work also.

    Thanks for the reply – do you know when you are likely to get time to upgrade the plugin to PHP 7.1?

    Found this page after spending time troubleshooting; I’m on php 7.1.2. Hopefully it is resolved soon! Any updates or should I downgrade to 7.0?

    Plugin Contributor Nick Young

    (@nickyoung87)

    Hello,

    First off, I apologize for the delay.

    Not sure of a time estimate to get things fixed for PHP 7.1 so at this time it is safest just to use PHP 7.0.x if you are able to.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Google API Error’ is closed to new replies.