Support » Installing WordPress » getting started/wp-config.php problem

  • hey,
    sorry, this is the basic-est of basic questions, but after changing wp-config.php to have all my database details and dumping all the files into my directory on my webspace, i just get that “sorry, database error” message where it says it can’t connect with the info i gave it. thing is, i’m pretty sure all the details are correct. this is what i have:

    // ** MySQL settings ** //

    define(‘DB_NAME’, ‘soyrev’); // The name of the database

    define(‘DB_USER’, ‘soyblog’); // Your MySQL username

    define(‘DB_PASSWORD’, ‘xxxxx’); // …and password

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    tried changing ‘localhost’ to the db hostname that i put in when creating my mysql database, but that didn’t work either. i was just wondering if anyone knew what i was doing wrong, and if they could explain what i have to do in very very simple terms. (i know practically nothing about all this)

    thanks for reading, and thanks for any help you can provide!!


Viewing 9 replies - 1 through 9 (of 9 total)
  • Mark (podz)


    Support Maven

    Who is your host, and do they have cpanel, vdeck, plesk or ensim control panels ?

    dreamhost. yeah, they have a control panel…which is how i made the mysql database. they have a knowledge base too but it’s not helping too much with this particular problem of mine.

    Mark (podz)


    Support Maven

    Isn’t the db_host wrong for DH ?
    It should be something like


    When I installed for somebody on dreamhost the DB_HOST was something like – exactly as you can see in the control panel when you click Goodies > Mysql.

    i think i tried that already but i might’ve just messed it up…i’ll try again in a jiffy and tell you if it works or not. thanks! 🙂

    so far so good. thanks guys! 🙂

    i am so confused.
    i am trying to get the wordpress installation up and going.
    Somehow, i screwed things up. it was working fine before, but now it gives me an error saying i entered one of the values in wrong. i am entering them in directly from the email i got from joomla, which tells all of the settings.

    is there a way to check all of the values, or maybe to start over?

    Who is joomla? 🙂
    Where is your WP install? – I cannot see it clicking on your name, just a listing of directories.

    hrm i seem to have figured out my blunder

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘getting started/wp-config.php problem’ is closed to new replies.