Support » Plugin: JW Player for Flash & HTML5 Video » Getting server errors after moving servers and upgrading

  • I have tried to uninstall and reinstall this plugin several times, upgraded and ftp installed and it just will not work. Here is the first error I am getting in the admin…

    View post on imgur.com

    I have already done everything this suggests (CHMOD’d every directory AND created other ones as I seen some suggest that resolved their issue) multiple times, nothing works. When I click install it just says I don’t have sufficient permission.

    The second error, is this shows up for all of the existing videos.

    Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity “JWPLAYER_PLUGIN_DIR/player.xml” in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 455

    Warning: Invalid argument supplied for foreach() in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 459

    Warning: opendir(JWPLAYER_PLUGIN_DIR/plugins/) [function.opendir]: failed to open dir: No such file or directory in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 337

    Warning: readdir() expects parameter 1 to be resource, boolean given in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 339

    Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity “JWPLAYER_PLUGIN_DIR/player.xml” in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 455

    Warning: Invalid argument supplied for foreach() in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 459

    Warning: opendir(JWPLAYER_PLUGIN_DIR/plugins/) [function.opendir]: failed to open dir: No such file or directory in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 337

    Warning: readdir() expects parameter 1 to be resource, boolean given in /home/html/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 339

    Fatal error: Call to a member function getDefaultValue() on a non-object in /home/videos/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 397

    I’ve already spent an entire day on it and not sure what to do.

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author JW Player

    (@longtail-video)

    Do you have a link to where this is running on your site?

    Yes, sorry I forgot to add it.

    http://bit.ly/tuW4ea

    Plugin Author JW Player

    (@longtail-video)

    Thanks. I have not seen errors like that before. Please leave this up so we can debug it.

    Ok, thank you.

    Plugin Author JW Player

    (@longtail-video)

    I’m sorry, but this seems to be an issue with file permissions. The second error is also about the plugin that is unable to read/write config files from a directory.

    Please make sure that your /wp-content/uploads/ directly is accessible by the use that executes the php. It is impossible for us to help you with that, because this depends on server setup. You’ll have to discuss this with your host.

    If for any we need to now your server setup. Which webserver, which version, which version of PHP, other plugins, WordPress version etc.

    I can screenshot this. I have already CHMODd 777, 755, 644, 705, ect. every possibility you can imagine numerous different ways. SFTP, FTP, File Manager.

    Still nothing. Kinda sucks because I have around 500 videos using this. Would take forever to manually alter.

    Plugin Author JW Player

    (@longtail-video)

    I’m sorry, but I am pretty sure it has something to do with your specific setup. I wish I could help, but I cannot without access to your server.

    I can give you access to the directory in question if that would help?

    Plugin Author JW Player

    (@longtail-video)

    I can have a look tomorrow if you want me to. You can mail credentials to support if you want to. Please use temporary credentials.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Getting server errors after moving servers and upgrading’ is closed to new replies.