Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.
If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).
Tried those things but something must still be cached somewhere because it doesn’t look like any plugins are disabled. I even renamed the theme folder and I still have the weird password only logon.
What I think would help is if I knew how the WordPress PHP flows when you try to access wp-admin/index.php. If I could trace that process I could figure out what file is creating the result I’m seeing in the browser.
Huzzah! Finally some progress. I was researching how to manually clear caching outside of the admin dashboard and found something to change in wp-config. That then gave me an error from the W3 caching plugin so I renamed the db.php file in the error mentioned, refreshed the page and finally got a proper logon! The IT Pro part of my brain wants to know what happened, but right not I’m happy that I didn’t have to resort to rebuilding my site.
Something evil got cached, which I suspected because as soon as I re-enabled the W3 Cache plugin, my problem returned. Manually reset things so I could get back in and deleted the plugin.
Once I was able to get back in I ran a security scan with WordFence and it looks like my site was indeed hacked. Found an encoded include in index.php.
Carefully follow this guide. When you’re done, you may want to implement some (if not all) of the recommended security measures.