Support » Plugin: WordPress Sentry » Getting Errors from dependency

  • Hey there!

    Great plugin! Unfortunately I just started getting errors on my login page and had to disable to plugin to be able to login.

    Here are the errors I am receiving:

    Warning: Unsupported declare ‘strict_types’ in /home/jacobmckinney/breathe-maintain/web/app/mu-plugins/wp-sentry-integration/vendor/zendframework/zend-diactoros/src/functions/create_uploaded_file.php on line 8

    Parse error: syntax error, unexpected ‘:’, expecting ‘{‘ in /home/jacobmckinney/breathe-maintain/web/app/mu-plugins/wp-sentry-integration/vendor/zendframework/zend-diactoros/src/functions/create_uploaded_file.php on line 19

    I haven’t been able to reproduce the issue locally, it only occurs on my production server.

    We are running plugin version 3.0.4 on PHP 7.3.11

    Any thoughts?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Alex

    (@stayallive)

    Hi Jacob,

    Ai, this is not good, you are the second person with this issue and I have been unable to reproduce myself 🙁 It almost sounds like you are not actually running 7.3 because the declare strict types should work on 7+.

    Maybe you can share some more details in the GitHub issue that was created for this?

    > https://github.com/stayallive/wp-sentry/issues/46

    I hope we can figure it out and find a reproducible case!

    Plugin Author Alex

    (@stayallive)

    We last spoke about a month ago, since I have not received a response I’ll assume the problems are resolved.

    If they’re not feel free to open up a new ticket.

    Als the ticket I mentioned from GitHub also got it resolved, so your problem might indeed have been similar.

    > https://github.com/stayallive/wp-sentry/issues/46

    Hey Alex,

    So sorry for the hiatus. I don’t know what the issue was, but I think it was on my end. Like I said I was never able to reproduce locally and later on the issue seemed to resolve itself. Very strange. I’ll post back here if it comes up again.

    Thanks for the prompt responses. Sorry I didn’t reciprocate.

    Plugin Author Alex

    (@stayallive)

    Hi Jacob,

    No worries at all! Glad to hear you got it working, that’s the important bit.

    If you do run into it later (or anything else), don’t hesitate to contact me again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Getting Errors from dependency’ is closed to new replies.