Support » Plugin: Shield Security » Getting blank page when previewing

  • Resolved rwilki

    (@rwilki)


    Hi. Awesome plugin. Some of my editors are seeing blank pages when they go to update a page or post. I’m not having the same issue. The only thing different from me to them is I’m whitelisted and they’re not. I think by adding their IP fixes the problem temporarily but IPs change. Is there something they’re doing that’s tripping this?

    Thanks,
    Bob

    http://wordpress.org/plugins/wp-simple-firewall/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Paul

    (@paultgoodchild)

    Hey Bob,

    How have you configured the plugin to react when it firewalls? Just die?

    Cheers,
    Paul.

    Great question Paul. Yes. Should I leave it on a message to throw us a clue?

    Thanks,
    Bob

    Plugin Author Paul

    (@paultgoodchild)

    Hey Bob,

    Yep, put it on the message so we can see a little bit clearly that it’s being blocked by the firewall.

    If you’re interested, you could could add a whitelist rule for that page/parameters and see if that solves it. Check out the FAQ

    The log would probably also tell you what the parameter is that’s being blocked… then you could do:

    post.php, blocked-parameter

    in your parameters white listing.

    Also, remove yourself from the IP whitelist so you can experiment with the whitelisting 🙂

    Let me know how that works.
    Cheers,
    Paul.

    Paul, I just ran across the problem that’s been occurring. I wasn’t seeing it because I had whitelisted my IP when setting up the plugin.

    Once I removed my IP from the whitelist, started recording logs, and added a message to the “die” function – I started seeing clues.

    The error message is: “Something in the URL, Form or Cookie data wasn’t appropriate.

    The log recorded the page html code and this:
    Page parameter failed firewall check.
    and the term matched was /0x[0-9a-f][0-9a-f]/i

    Any ideas? I’m getting this problem on every site I use your plugin on…

    Thanks,
    Bob

    Plugin Author Paul

    (@paultgoodchild)

    Okay, it’s matching on one of the WordPress terms and it’s probably because you have an image in that page.

    For now, if you turn off the sub-section that does the WordPress Terms checking in the firewall you should be ok. I’ll add a rule into the plugin to cater for this in the next release.

    Cheers,
    Paul.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting blank page when previewing’ is closed to new replies.