Support » Theme: Gateway » Gateway customizer error for Blog

  • Resolved alexarowan

    (@alexarowan)


    Hi, I’m trying to add a blog that is not the front page (I’m using a static front page and a self-hosted instance of WordPress.org at http://www.alexarowan.com), and there is no way to remove or alter the sample text/heading.

    I searched the support archives and this issue was posted a few months ago, and the suggested resolution was to use the customizer. The customizer does not show Blog as an option. It’s just not there. I looked at the css and php files (actually, I tinkered with them and then crashed my site–not doing *that* again!) and saw that there *should* be a Blog option in the customizer. But it doesn’t appear. The previous user’s resolution was to upgrade to Plus, but it seems incredible to me that a richly-featured theme like Gateway purposefully has prevented users from customizing their Blog page. Hope someone can look into this, as I love the theme otherwise!.

    Thanks,
    Alexa

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author Rescue Themes

    (@rescuethemes)

    Hi Alexa,

    To create a blog page, all you need to do is assign a page at:

    Settings > Reading > Posts Page: “Your blog page”

    The blog page you assign can be without content.

    http://d.pr/i/unuY

    There’s documentation available below as well:

    http://docs.rescuethemes.com/article/49-gateway-create-the-blog-page

    Hi, thanks for responding. My issue isn’t that I can’t create a blog page. I have created a blog page at http://alexarowan.com/blog, and my issue is that I can’t find anywhere to get rid of the sample header that says:

    “Latest News

    Change these titles to anything in the customizer.”

    Here’s a screen cap.

    I can’t change the sample text in the customizer (I’m using the Gateway Free version) because there is no option to do so, and I can’t find a way to edit that text in the editor in WordPress.org.

    Thanks very much,
    Alexa

    Theme Author Rescue Themes

    (@rescuethemes)

    Hi Axexa,

    You change that text in Customizer > Theme Options > Blog

    Thanks for the quick response. The Blog option doesn’t exist in the Customizer > Theme Options. Please see my screen cap at http://tinyurl.com/zpx2mhv.

    There is an error in your Customizer for the Free version such that Blog isn’t an option to customize, making it impossible to edit or remove the sample text shown in the screen cap in my previous post.

    Thanks very much,
    Alexa

    Theme Author Rescue Themes

    (@rescuethemes)

    Alexa,

    I just realized that I hadn’t pushed the latest update to wordpress.org. It does include the Customizer > Theme Options > Blog setting. I will try to get this uploaded today.

    Theme Author Rescue Themes

    (@rescuethemes)

    Alexa,

    I just realized you might not be seeing the Customizer > Theme Options > Blog because you aren’t looking at the Blog page. The Customizer is smart enough to only show you options for the page you are currently viewing.

    Also, what do you have set in Settings > Reading > Front page displays? Is it latest posts or static? If it is static, what do you have set for Posts page?

    I updated the database and also added my blog page to the menu (which I hadn’t wanted to do when I couldn’t update the default text), clicked to open the blog page when I was in Customizer, and the Customizer > Theme Options > Blog menu appeared. Brilliant! Thanks very much. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.