Support » Plugin: Media Library Assistant » FYI Version incompatibility

  • Resolved jaywoods

    (@jaywoods)


    Just thought I’d mention an issue I had with an older version of the plugin (0.1), which looks really useful btw.

    I’m on WordPress 3.1.2 and the current plugin version requires 3.3, so I installed an older version of the plugin (v0.1) which would meet the minimum wordpress requirements (v3.1) specified in the readme.txt. However, when I installed the plugin I was immediately taken to a screen reading “The “Media Library Assistant” plugin requires WordPress 3.3.0 or newer; you have 3.1.2. Contact your system administrator about updating your version of WordPress.”

    I was then completely unable to access the backend of worpress until someone with the credentials to delete the file from the server was available. In my case, the system administrator was out of the country. I’m pretty new to WordPress so forgive me if installing older plugin versions is a no-no.

    http://wordpress.org/extend/plugins/media-library-assistant/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Lingren

    (@dglingren)

    Please accept my apologies for your bad experience. It’s my fault and you did nothing wrong!

    The README.TXT file for version 0.1 is wrong (as you discovered). I’m going to go back and change it to conform to reality (v3.3 required).

    I didn’t think carefully enough about handling the case where the version compatibility check fails, and the black hole you fell into is inexcusable. I will fix that in my next release.

    Thank you for taking the time to report this problem. I hope you’ll give the plugin another chance when your site gets upgraded to a more recent version of WordPress.

    Plugin Author David Lingren

    (@dglingren)

    I have released version 1.14, which changes the way version compatibility failures are reported and fixes the black hole you fell in to.

    THanks again for bringing this issue to my attention.

    David

    Cool, thanks! I look forward to trying it out just as soon as the system administrator gets back from overseas.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘FYI Version incompatibility’ is closed to new replies.