WordPress.org

Support

Support » Installation » [Resolved] function.require problem after restore

[Resolved] function.require problem after restore

  • missmoffat

    @missmoffat

    Hello

    A site I have worked on has been hacked – Google is listing it as suspicious and has a warning message up on it. I investigated and saw that the only thing to do was delete the current site and restore it from a backup. I’ve just done this via Filezilla but when I go to the site it brings up this error message:
    Warning: require(/home/petrabis/public_html/wp-includes/class-wp.php) [function.require]: failed to open stream: No such file or directory in /home/petrabis/public_html/wp-settings.php on line 70

    Fatal error: require() [function.require]: Failed opening required ‘/home/petrabis/public_html/wp-includes/class-wp.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/petrabis/public_html/wp-settings.php on line 70

    I can see no class-wp.php document in the wp-includes folder and so am baffled as to how to resolve this. Any advice very gratefully received – the site has been down for a week now and my client is anxious of course for it to be up and running again. Many thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi

    @esmi

    Forum Moderator

    I can see no class-wp.php document in the wp-includes folder

    I do. Try re-downloading a fresh copy of WordPress.

    missmoffat

    @missmoffat

    Thanks for this – it was that simple! My backup for some reason didn’t have the class-wp.php document but the latest download of WordPress did – phew!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] function.require problem after restore’ is closed to new replies.
Skip to toolbar