WordPress.org

Support

Support » Plugins and Hacks » [Resolved] function in_array: Wrong data type for second argument

[Resolved] function in_array: Wrong data type for second argument

  • linux4me2
    Participant

    @linux4me2

    I’m using Marketpress Lite 2.5.1 on a WP 3.5.1 site in a Twenty-Ten theme.

    When a user clicks a Category tag in a product listing, multiple warnings like this are thrown:
    [20-Mar-2013 18:30:59] PHP Warning: in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in /home/<my server user name>/public_html/wp-includes/post-template.php on line 1039

    This does not occur when the user clicks Category tags in posts.

    It looks like the same issue discussed here, where they say a fix was released a couple of months ago in version 2.8. It appears that is the Pro version. Is there a fix in an upcoming version of Marketpress Lite? Is there a workaround in the meantime?

    http://wordpress.org/extend/plugins/wordpress-ecommerce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • @linux4me2

    Hi There, a new version is on the way it was delayed slightly to incorportate some last minute new features.

    Cheers

    Tom

    federicoh
    Member

    @federicoh

    Same issue here error showing on some categories

    federicoh
    Member

    @federicoh

    This is what worked for me:

    I didn’t have a custom menu, I recreated my menu in Appearance – Menu, just like the one I used to have and I don’t get any more errors messages. Good luck

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] function in_array: Wrong data type for second argument’ is closed to new replies.