Support » Theme: SoloFolio » Front page slider

  • Resolved Liviu Cezar

    (@liviu-cezar)


    Hello!

    I am building a portfolio based on SoloFolio template. And I want my front page to be like a slider (like this photographer manage to do on his website: http://matteichphoto.com/ ).

    Actually like a gallery where the user cannot access the thumbnails zone.

    How can I do that?

    Tank you for your help!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Theme Author jhawksley

    (@jhawksley)

    Liviu,

    To disable thumbnails, add thumbnails_enabled=”false” to your gallery shortcode like so:

    [gallery thumbnails_enabled="false"]

    Joel

    Thank you! 🙂

    Theme Author jhawksley

    (@jhawksley)

    You’re welcome!

    Hi, I’m trying to set up the portfolio galleries as listed here: http://solofol.io/galleries/

    When I update my home page with the gallery added, the theme breaks and this error code appears:

    Fatal error: Cannot redeclare solofolio_cyclereact_thumbs_style() (previously declared in eyeofvoir.com/wp-content/themes/solofolio/includes/gallery-cyclereact.php:10) in eyeofvoir.com/wp-content/themes/solofolio/includes/gallery-cyclereact.php on line 16

    What can I do to fix this? I am using WordPress 4.1 with all plugins disabled and I downloaded your theme from the WordPress theme directory. HELP!

    Theme Author jhawksley

    (@jhawksley)

    iamtrevoir.com,

    Can you try downloading the latest version from https://github.com/joelhawksley/SoloFolio/archive/master.zip?

    Joel

    Hi Joel,
    I love what I see in the theme, it is exactly what I have been looking for but… sorry mate – there is always a but… I am having the same issue with the fatal error, I have tried the latest version you linked to however when I use that theme the gallery doesn’t load correctly – it looks exactly like the visual editor does – luckily it isn’t a “live” site as such so I can leave it there for you to see at http://www.rjames.net/en

    Thanks,
    Ryan

    I just found the problem and it seems to be a compatibility issue with JetPack.

    I have just turned off and on all JetPack modules that I planned on using to check what may be breaking the theme however it is still broken until JetPack is completely disabled.

    For me this is very disappointing as I use JetPack for multiple features on other sites that I run and was hoping to use some on this site also.

    Do you have plans to integrate your theme for JetPack?

    Thanks!
    Ryan

    Theme Author jhawksley

    (@jhawksley)

    h8usernames,

    I should probably mention in the documentation that SoloFolio does not currently play well with Jetpack. It’s on my list of things to work on.

    Joel

    Hi Joel,
    Thanks for the quick reply, when you posted your reply I was actually editing my previous post.

    For now I guess I will have to do without JetPack and look forward to when SoloFolio and JetPack are best buds!

    I would definitely agree that this should be in the documentation that otherwise is very good. I was also impressed that SoloFolio plays nicely with Polylang as it is the 1 plug-in that I cannot live without as I service both English and Portuguese speaking markets.

    Thanks again,
    Ryan

    Hi!

    How can I add in Solofolio Social Media Widget other links like Google Plus, for example?

    Theme Author jhawksley

    (@jhawksley)

    Liviu,

    SoloFolio currently supports a limited number of social media icons.

    I’ve filed your idea here: https://github.com/joelhawksley/SoloFolio/issues/248, and hope to implement it soon.

    Joel

    Theme Author jhawksley

    (@jhawksley)

    Liviu-

    I’ve implemented your idea here:
    https://github.com/joelhawksley/SoloFolio/pull/251

    I’ve submitted the update to WordPress, but in the meantime you can download 7.0.102 here: https://github.com/joelhawksley/SoloFolio/archive/master.zip

    Joel

    I’d also like to emulate the homepage of http://matteichphoto.com/. I notice that he has both a slideshow and a hidden side menu. How can I do this?

    The only way I know to hide the side menu is by setting the template to “Story Page”, but that makes the slideshow stop working.

    Thank you

    Theme Author jhawksley

    (@jhawksley)

    Sean,

    Add type="solofolio" thumbnails_enabled="false" to your gallery tag:

    [gallery type="solofolio" thumbnails_enabled="false"...

    Thank you for the quick support!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Front page slider’ is closed to new replies.