Support » Theme: Preference Lite » Footer Copyright Customization

  • Resolved ADQ



    I modified footer.php and uploaded it to the child theme folder adding my name to the copyright line but it does not display.

    Any advice would be appreciated.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Michael


    Forum Moderator

    I modified footer.php and uploaded it to the child theme folder

    please post the full code of the modified file (please use the pastebin as described in )

    what is the output?
    are you using any cache plugins?

    Hi: I also attempted to modify the footer.php, so I can change the footer of the site I’m helping to manage (
    The default footer says:
    Copyright © 2013 Your Name. All rights reserved.

    I thought I could change that via Editor/footer.php. I swapped in the name change I wanted here:
    <div><?php esc_attr_e('Copyright ©', 'preference'); ?> <?php esc_attr_e(date('Y')); ?> <?php echo get_theme_mod( 'site_copyright', 'THIS IS THE NAME OF THE WEB SITE I WANT ADDED HERE' ); ?><?php esc_attr_e('. All rights reserved.', 'preference'); ?>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    However, after saving that change, the default tag still appears (Copyright © 2013 Your Name. All rights reserved. ).

    I welcome guidance to correct what I may be doing wrong. Thank you!

    Theme Author Styled Themes


    No need to modify the file(s) because the theme customizer has a copyright field you can use. Go to your home dashboard, click on “Customize your site” button, then go to Basic Settings, then change the name in the field to your own. The date and copyright symbol are precoded and keeps up to date.

    How do you turn “Your Name” into a link to another site?

    Theme Author Styled Themes


    You would have to modify the footer.php file code and hard code the link in there by wrapping the link around the copyright or take out the full code and add your own code to replace what is there.

    I cannot locate the customize your site button. I upgraded to 3.7.1.


    Theme Author Styled Themes


    It will be on your admin’s home page of the dashboard, or you can go to Appearance >> Customize

    I am also having difficulties. I went into “Appearance >> Customise >> Basic Settings >> Copyright Notice”. In the box, I deleted “Your Name” from the default text and replaced it with “Shepherd Shaw”. I then hit the “Save & Publish” button. Unfortunately, the copyright notice remains unchanged (see the website at I have put the correct copyright message in the Footer 1 widget area, but the default copyright message remains. Can you suggest a fix (PS: I know almost nothing about coding).

    Mark Shepherd

    Theme Author Styled Themes


    Aw man… I’m not sure how that got in this update because it worked before. However, no excuses on my part because it’s totally my fault. I will have to do another update to fix this. In the meantime, contact me from my website and I will send you the theme update that will solve this.



    I’ve used the following on a couple of sites – works great.

    <?php esc_attr_e('Copyright ©', 'preference'); ?><?php _e(date('Y')); ?><?php bloginfo('name'); ?>  All Rights Reserved | Website by <a href="" title="Website by">TGD Web Designer</a>

    Copy the footer.php file to the child theme folder, and replace the div for the copyright with the above, Replace your text after the pipe “|” character, to whatever you want and change the href and link title to whatever you want. PS. above URL does not exist.
    Can’t stress how important it is to use Child Themes. Andre makes it easy for you. Many thanks to Andre.

    tgd you’re a legend thankyou!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Footer Copyright Customization’ is closed to new replies.