WordPress.org

Support

Support » Plugins and Hacks » [Resolved] fix for image upload in wp 3.6

[Resolved] fix for image upload in wp 3.6

  • michapixel
    Member

    @michapixel

    In RCCWP_WritePostPage.php

    ~ line 1763
    replace
    endif; (that’s from if(!is_wp30()): some lines earlier)
    with

    else : ?>
    <script>
    jQuery('a#thumb_<?php echo $idField ?>').click( function(){
     window.mf_field_id = jQuery(this).attr('id');
    });
    </script>
    <?php	endif;
    ?>

    that should insert the required “mf_field_id” and you got your “Set image in field”-button back.

    http://wordpress.org/plugins/magic-fields/

Viewing 5 replies - 1 through 5 (of 5 total)
  • dc23
    Member

    @datenchef

    Great! Do you have any similiar idea for v2? Thx a lot.

    michapixel
    Member

    @michapixel

    Should be similar i guess. I don’t use v2.

    Motion FM
    Member

    @motion-fm

    It worked! Thank you much.

    I have version 1.6.1.

    another13
    Member

    @another13

    For Mafic Fields 2, in magic-fields-2/field_types/image_media_field/image_media_field.php.

    After:
    $out .= sprintf(‘%s‘,$field[‘input_id’],$link,__(‘Set Image’,$mf_domain));

    Add:
    $out .= “<script>
    jQuery(‘a#thumb_”.$field[‘input_id’].”‘).click( function(){
    window.mf_field_id = jQuery(this).attr(‘id’);
    });
    </script>”;

    It work for me. 🙂

    Plugin Author hunk
    Member

    @hunk

    fixed in new version MF 1.6.1.1, thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] fix for image upload in wp 3.6’ is closed to new replies.