Support » Plugin: Safari Push » Finally….

  • Resolved azchipka


    Ok so after a lots of trial and error I finally got my push server to prompt for permissions and all that nonsense.

    For those who are having trouble with that issue its easily resolved by following the directions for the certificates (p12 and pen) files found on the apple developer website here.

    So with that problem out of the way I now move on to the plugin issue. I have the plugin installed.

    From the website itself (the one with the plugin installed), I get the prompt requesting permission but I am not getting the test pushes and after sending a test push I simply get a white screen located in the v1 directory.

    push server:
    page where push notifications come from:


Viewing 4 replies - 1 through 4 (of 4 total)
  • Ok i got the push notifications going to units but there is one small problem left.

    When you click on the push notification it is going to the following URL:

    Even though I have the config file set to:
    define(‘URL_FORMAT’, ‘’);

    As a result of going to HTTPS its getting the index file from my push server configuration instead of the blog.

    Do the push notification system need to be running a completely different domain name than the site where the push notification is routing to on click?

    Small correction on the previous post that I hadn’t noticed till now.

    The url being passed is actually the URL of the push server regardless of what is in the config.php file

    So long and the short is that it seems like certain things are also being ignored. For example I have the Button Label set to “view” in the plugin settings but there is no button showing on my notifications.

    It does pass the end portion of the URL correctly.

    Ok finally got it working correctly!

    Plugin Author macgamer



Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Finally….’ is closed to new replies.