Support » Fixing WordPress » File Permissions?

  • Resolved btwebster


    I have a local install of WordPress and run it with XAMPP. I do this so that I can make major changes to my website offline. But when I try modifying the style sheet I get a message saying that I must make the file writable before saving the changes. The message provides this link to the codex:
    I find the entry confusing and useless to help me solve this problem. I can make changes to the style sheet directly using my text editor, why can’t I save changes through wordpress? More importantly, how and where do I change the file permissions for wordpress?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Some FTP clients can edit file permissions (“CHMOD”), otherwise the file manager of your control panel.

    If you’re on windows, select the files in theme’s folder, right-click (goto properties), see if read-only is checked, if it is, uncheck it and apply the changes..

    CHMOD isn’t available under windows explorer, but the above should do pretty much the same (i think – i don’t have this issue with my local install).

    “Local” of course, I should have read better!

    Thanks t31os_

    I’m actually on Mac but I used Finder > Get Info to change the file to read & write for Me, staff, & everyone. It worked. I figured read & write for the administrator would be enough. Guess not. Thanks for the quick responses. As usual, it was easier than I thought at first.

    I’ve never used Macs, but i’d have assumed the procedure was just as simple.

    Glad you got it sorted… 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘File Permissions?’ is closed to new replies.