• Resolved kdsfdksn

    (@kdsfdksn)


    OK, Please allow me changed the way to ask.

    I haven’t update Yoast SEO for a very long time.

    When I trying to update the plugin from [Yoast SEO Ver 15.1] to [Yoast SEO Ver 19.10], I got following Warnings & Fatal error & Uncaught Error.
    FYI: My website WordPress version is 6.1.1
    But the plugin update page also shows “Yoast SEO updated successfully.”

    I am really confused, what is going on???
    This happened is because “when the plugin files are cached and some old files are still used after updating the plugin.” ?

    Please see the details below.

    devnihil (@devnihil) Please help
    Thank You
    Best Regards

    ———————-

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Enabling Maintenance mode…

    Updating Plugin Yoast SEO (1/1)
    Yoast SEO updated successfully. Show details.

    Disabling Maintenance mode…

    Warning: include(/home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/vendor/composer/../../inc/class-my-yoast-api-request.php): failed to open stream: No such file or directory in /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/custom-facebook-feed-pro/vendor/composer/ClassLoader.php on line 478

    Warning: include(): Failed opening ‘/home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/vendor/composer/../../inc/class-my-yoast-api-request.php’ for inclusion (include_path=’.:/usr/local/php74/pear’) in /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/custom-facebook-feed-pro/vendor/composer/ClassLoader.php on line 478

    Fatal error: Uncaught Error: Class ‘WPSEO_MyYoast_Api_Request’ not found in /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php:406 Stack trace: #0 /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php(566): WPSEO_Addon_Manager->request_current_sites() #1 /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php(107): WPSEO_Addon_Manager->get_site_information() #2 /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php(118): WPSEO_Addon_Manager->get_subscriptions() #3 /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php(215): WPSEO_Addon_Manager->get_subscription(‘yoast-seo-wordp…’) #4 /home/customer/www/examplewebsite.com/public_html/wp-includes/class-wp-hook.php(310): WPSEO_Addon_Manager->check_for_updates(Object(stdClass)) #5 /home/cust in /home/customer/www/examplewebsite.com/public_html/wp-content/plugins/wordpress-seo/inc/class-addon-manager.php on line 406
    There has been a critical error on this website. Please check your site admin email inbox for instructions.

    Learn more about troubleshooting WordPress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello @kdsfdksn

    I’m sorry about the fatal error. Can you provide more details?
    1. Has the error prevented you from logging into your WordPress dashboard?
    2. Is the site frontend affected?
    3. Can you share the website URL?

    Thread Starter kdsfdksn

    (@kdsfdksn)

    Thank you for replying @maybellyne

    1. The warning messages and fatal error only shows up once, when i was updating the plugin in the production environment (with CDN).
    2. No affected at all. But I am trying to make sure it won’t cause any potential issues.
    3. I tested it again in a testing environment (without CDN), this warning messages and fatal error didn’t shows up again.

    ————————–
    I have investigated for more details shown as below.

    For Yoast SEO Premxxx Ver15.1, “/wordpress-seo-premxxx/inc/class-addon-manager.php” this path exist.
    But for Yoast SEO Premxxx Ver19.5, “”/wordpress-seo-premxxx/inc/” this path is not exist.

    Also my website has CDN service, it maybe the reason for “when the plugin files are cached and some old files are still used after updating the plugin.” ?

    My assumption is the path is not exist and CDN cache caused this issues.
    Is it seems like a temporary issues happened during the update?

    ————————–

    Please don’t mark this topic as resolved, until there is a reasonable explanation for why this warning messages and Fatal errors shows up during the update.

    I really appreciate.

    Plugin Support Maybellyne

    (@maybellyne)

    Thanks for the clarification. Since the functionality of your website isn’t affected, those were temporary errors generated during the plugin update. And it’s understandable since you updated from an old version.

    As I confirmed in your previous topic and this last reply corroborated, you have the Premium plugin but this forum is for supporting the free version. So I am closing this topic. If you require further assistance, please contact the Yoast support team via email.

Viewing 3 replies - 1 through 3 (of 3 total)

The topic ‘Fatal Error happened during update’ is closed to new replies.