WordPress.org

Support

Support » How-To and Troubleshooting » Fatal Error after moving host

Fatal Error after moving host

  • Hello

    I have an issue that is literally driving me insane.

    started out with a wp blog on a friends server. Tested the Craviora theme for my blog and really liked it.

    – blog works fine on http://web.mymatesdomain.co.uk/dan/blog/
    -created a subdomain that points to public_html/blog ( off my my domain)
    – copied all the wp directories from the current server to pubic_html/blog
    – exported the current database file to a .sql file
    – text search and replace references: http://www.mymatesdomain.co.uk/dan/blog/ with http://www.mysubdoman.mydomain.biz
    – changes a few relative paths to point from “public_html/dan/blog” to “/”
    – imported the amended .sql file
    – change settings in wp-config.php for my newly created database
    – when the first post is rendered and next to the comment section I get the following:
    Fatal error: Only variables can be passed by reference in /public_html/blog/wp-content/themes/craviora-free/craviora/includes/custom-pings.php on line 15

    Line 15 looks in the file
    $comments_by_type = &separate_comments(get_comments('post_id=' . $id));

    Neither my hosted blog or my friends hosted blog has any comments associated with this post however the lookup seems to be causing the problem.

    Please can anyone help

    Daniel

  • The topic ‘Fatal Error after moving host’ is closed to new replies.
Skip to toolbar