WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Plugin: Intense Debate Ver 2.9.1 (Fatal Error)

[Resolved] Plugin: Intense Debate Ver 2.9.1 (Fatal Error)

Viewing 15 replies - 1 through 15 (of 17 total)
  • How do you go back to version 2.9? My installation broke, too.

    Thanks,
    K

    I have the same problem, and I’m not able to access my dashboard or anything. Only this comes up:

    Parse error: syntax error, unexpected ‘{‘ in /home/content/34/7238734/html/wp-content/plugins/intensedebate/intensedebate.php on line 467

    I would also like to know how to return to 2.9.

    Thanks,
    Chris

    Same error for me on WordPress 3.1.2 Network. Here’s how I fixed it.

    1. Download 2.9 from the repository.
    2. Access your site via FTP and delete the intensedebate folder under wp-content/plugins.
    3. Upload the 2.9 version.
    4. Reactivate via WordPress admin.

    add me to the list of the error

    “Parse error: syntax error, unexpected ‘{‘ in /nfs/c03/h04/mnt/50940/domains/secularleft.us/html/wp-content/plugins/intensedebate/intensedebate.php on line 467”

    Same error, just went back to 2.9

    To fix this error, go to line 467 of intensedebate.php

    Change:

    f ( ! in_array( $comment->comment_approved, apply_filters( 'id_comment_approved_blacklist', array( 'spam' ) ) ) ) {

    To:

    if ( ! in_array( $comment->comment_approved, apply_filters( 'id_comment_approved_blacklist', array( 'spam' ) ) ) ) {

    They have an ‘f’ instead of an ‘if’

    Thanks @mccomb

    Thanks @mccomb. Props.

    Moderator James Huff

    @macmanx

    Support Team Rep.

    We apologize for the delay. We were working hard a fix and we now have it ready in the 2.9.1 version of IntenseDebate (we decided not to bump the version number for this). There are three ways to fix this depending on your level of access:

    1. Delete the plugin from the Plugins section of your blog’s Dashboard and reinstall it.

    2. If you cannot access your Dashboard, you’ll need to access your server via FTP or SFTP http://codex.wordpress.org/FTP_Clients and navigate to the /wp-content/plugins/ directory. Once there, delete the /intensedebate/ directory and all of the files within. Once that is done, return to the Plugins section of your blog’s Dashboard and reinstall the plugin.

    3. If you cannot access your server via FTP or SFTP, please contact your hosting provider to remove the /wp-content/plugins/intensedebate/ directory and files for you, then reinstall from the Plugins section of your blog’s Dashboard.

    Please note that neither of these reinstall methods will affect your existing comments.

    We apologize for the inconvenience.

    mccomb, thanks for dropping by to post the fix!

    I couldn’t reppair the issue. I followed the first 2 ways. Following the first one I couldn’t access to any section of my dashbord, not even to the login page:

    http://todofitness.cl/wp-login/

    Following the second one, which already tried to fix other plugins’ bugs, I didn’t found an “Intensedebate” directory in /wp-content/plugins/. So I couldn’t delete something that didn’t exist.

    Then I tried a third one: to upload the zip file to ftp to modify intensedebate.php just like @mccomb suggests. But the ftp file manager, after uploading de the file, couldn’t unzip it. So, I decided to unzip it in my hard disk, check the intesedebate.php file there and then upload file by file to the ftp server. The intesedebate.php was correct. So, all files were uploaded manually and one by one. But this way didn’t solve the issue either

    Any idea? After that, I’m too anxious to replace IntenseDebate by Disqus…

    Thanks a lot…

    @egoipse – look for the following directory “wp-content/plugins/intensedebate”

    It is there or you wouldn’t get the error.

    I used an FTP program but you should still be able to delete it through an FTP manager.

    Just delete the directory and then try to go to your dashboard again – might need to clear your browser cache.

    Once you get back into it go to the plugins section and install the fixed file through the “Install” part of the plugin dashboard

    Thank you cadfile for the answer…

    The directory doesn’t appear nor in ftp web manager nor in the desktop ftp client. So, I couldn’t delete it…

    Sorry to hear that egoipse. Like I said you wouldn’t get the error if the directory didn’t exist.

    You might want to contact your server provider tech support and have them delete it for you.

    Ok. I’ve just tried another way: deleting all “plugins” directory. But it didn’t work either. I still get the fatal error. So, there’s another modification introduced by the plugin that I cannot find.

    IntenseDebate won’t take responsability for the economic damage its bug is producing, won’t it?

    I just went to your site and this is the error message:

    “Parse error: syntax error, unexpected ‘{‘ in /home/todo_fitness/todofitness.cl/wp-content/plugins/intensedebate/intensedebate.php on line 467”

    So make sure you look for in the todofitness.cl/wp-content/plugins/intensedebate

    I had the same error message deleted the directory and was able to access my dashboard again. The fix for the issue is posted here by the plugin writers so there isn’t much more they can do since they don’t have direct control of your install.

    I would really recommend you submit a ticket to your hosting people.

    Hope it works out for you

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Plugin: Intense Debate Ver 2.9.1 (Fatal Error)’ is closed to new replies.