Support » Plugin: WP Admin Audit » Fantastic !

  • I just tested this plugin, and it is fantastic. The Search list in the logs works like a charm, besides events, I can search for logs for individual users as well, and also the way we can filter the log is great too !

    The only thing that worries me for now, is that in the settings page, when I’m setting the “Keep events for:” is not “registering”. After saving the my changes, every other change made on the Settings page, is being shown correctly, but the “keep events for:” field, becomes empty from the number of days I had set it to. The plugin however correctly logs the change, and right now I have it for 1 day. In a day or two perhaps, it will be clear if that part of the settings page actually works.

    It would be nice if we could manually delete the logs, and also have the ability to export them…

    Update: Looking at the database values, it seems that the correct value to keep the events for is set (1 day in my test case), so it’s a matter of displaying the value in the settings page, and not actually setting it. I am also guessing that to manually delete all the data, is to set the setting to delete all the data when the plugin is uninstalled, and then uninstall and reinstall it again, or manually delete the records from the database, which for many users would be a dangerous task…

    BTW: Tested on Xampp Localserver, Windows 10, PHP 7.4.x, Chrome Browser, WP 5.9, with many plugins active among them Gutenberg 12.5.0 RC1.


Viewing 1 replies (of 1 total)
  • Plugin Author brandtoss


    Hello Nick!

    Thank you very much for your great review and for sharing your observations.

    The problem with the settings saving will get addressed with the next release.
    And your ideas to manually purge the log and to create exports are also very welcome.

    Feel free to connect here or directly ( with me if you want to discuss other ideas and/or want to join the list of beta testers for our coming pro-version(s).


Viewing 1 replies (of 1 total)
  • The topic ‘Fantastic !’ is closed to new replies.