WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Fall-in-love theme comment errors

[Resolved] Fall-in-love theme comment errors

  • I’m receiving the following errors when using the Fall-in-love theme. I tried emailing the author quite a long time ago (at least a month, if not more). Didn’t receive any response from him and it looks like his site hasn’t been updated lately, so wondering if he disappeared…

    Anyway, the errors–

    Warning: comments_template(/dir/user/www/wpress/wp-content/themes/fallinlove): failed to open stream: Success in /dir/user/www/wpress/wp-includes/comment-functions.php on line 26

    Warning: comments_template(/dir/user/www/wpress/wp-content/themes/fallinlove): failed to open stream: Success in /dir/user/www/wpress/wp-includes/comment-functions.php on line 26

    Fatal error: comments_template(): Failed opening required ‘/dir/user/www/wpress/wp-content/themes/fallinlove’ (include_path=’.:/usr/local/lib/php-pear’) in /dir/user/www/wpress/wp-includes/comment-functions.php on line 26

    I tried downloading the theme again and installing it in a new directory…still receive the errors on that install. I have other themes, and when switching to them, I do not receive the errors.

    If anyone can help me out here, I’d sure appreciate it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Any suggestions? I really don’t want to abandon this theme as I’ve made some customizations to it and really like the layout. I just hate to put in more time if I can’t fix it… 🙁

    Was it ever working for you? If so, try to remember when you did prior to it not working.

    I wish it was that simple. No, it was never working for me. To make sure it wasn’t anything I did or that possibly I had a bad download, as I stated, I tried downloading the theme again and installing it in a new directory…still receive the errors on that install. I have other themes, and when switching to them, I do not receive the errors. It is theme-related…I just don’t where to fix it.

    Just found that someone else has posted about this as well and also had no luck contacting the theme developer…
    http://wordpress.org/support/topic/57709?replies=3

    And it was also noted in this thread:
    http://wordpress.org/support/topic/56768?replies=7

    I started thinking about it being a “static” page that was the only type of page creating the error… So, checked out other themes to see the difference… The difference ended up being there was no page.php file. (There is not one in Dilip’s Aesthetic theme either, so this solution should work for it as well.)

    What I did was to create a page.php file and put it in the fallinlove theme directory…

    Although I know next to nothing about php (that’s my disclaimer), from experimenting, it appears the contents of that file need to be at minimum:

    <?php get_header(); ?>

    <div id="post-<?php the_ID(); ?>" class="post">
    <h3 id="post-<?php the_ID(); ?>"><a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h3>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <?php the_content(__('Read more »')); ?>

    <?php
    wp_link_pages();
    ?>
    <!--
    <?php trackback_rdf(); ?>
    -->
    </div>
    <?php endwhile; else: ?>
    <p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    <?php endif; ?>

    <?php get_footer(); ?>
    </div>
    </body>
    </html>

    I hope this will help others.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Fall-in-love theme comment errors’ is closed to new replies.
Skip to toolbar