Support » Fixing WordPress » ‘Failed to write file to disk.’

  • When I try to upload an image it gives me the error: ‘Failed to write file to disk.’

    I don’t understand why i have this problem the permision is at 777, i readed here that i have to change something in the ini.php, but i can’t find where it is, it’s missing. Please help me with an advise.

    Kind regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having the exact same issue. Anyone have any idea how to resolve?

    I just started having this issue as well. Everything has been working fine until this evening. As far as I know nothing has changed.

    Today I started experiencing this issue as well after successfully uploading several photos. I did an extensive search on this forum and Google I was amazed to not find a clear resolution. This lead me to searching through the WordPress core files for the error message to see what was going on. The error message seemed to be triggered after the file was uploaded to the temporary directory where php stores the newly uploaded file. I did not have access to this directory, so I contacted my host and they were able to repair/remove the temporary files in the directory. This immediately resolved the issue for me and I hope this helps resolve it for all of you.


    Assign 766 recursive permissions to wp-contents directory of your blog and also add this code in htaccess:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Make sure that you have set the proper upload directory path from wordpress admin area -> settings -> miscellaneous settings.


    Shane G.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘‘Failed to write file to disk.’’ is closed to new replies.