WordPress.org

Support

Support » How-To and Troubleshooting » Facebook Thumbnail Issue. Really need some help.

Facebook Thumbnail Issue. Really need some help.

  • 21CB
    Member

    @21cb

    I am desperate for help with this issue. I am on the verge of tears, I have been trying to fix this for months and have tried so many things in combination I’m struggling to keep it straight in my head.

    I have added og meta tags, inserted new code in the header and/or functions, tried plugins, every piece of advice I can find. I still cannot get thumbnails to display on my links when posted on Facebook, and it is really affecting my traffic. If a link doesn’t have an eyecatching thumbnail, most people don’t seem to bother clicking it.

    If anyone would be willing to help me, I would be so so grateful. I can provide copy of code and links etc.

Viewing 15 replies - 1 through 15 (of 39 total)
  • 21CB
    Member

    @21cb

    Anyone? Please?

    voala
    Member

    @voala

    Usually, facebook selects the first image it comes across on your page or blog post. You can take a look at this page: http://wordpressdevelopment.com/blog/tips/how-to-specify-a-facebook-thumbnail-when-sharing-a-post/

    21CB
    Member

    @21cb

    Thank you so much. Unfortunately this is something I have already tried, with no success.

    voala
    Member

    @voala

    Ok, Try this out.
    http://www.wpbeginner.com/wp-themes/how-to-avoid-no-thumbnail-issue-while-sharing-post-on-facebook/

    [Code moderated as per the Forum Rules. Please use the pastebin]

    As this link says, you go to functions.php of your theme folder and insert this code (inside the PHP brackets). Replace the http://example.com/image.jpg with the location of the image you want to display when the post has no featured image set to it.

    By the way, you use featured images to your pages or blog posts?

    voala
    Member

    @voala

    P.S. The first solution did not worked because that is a fix for static pages, not dynamic like wordpress is. Hope this works.

    21CB
    Member

    @21cb

    Thank you, but I already have this code in functions as well. I do have featured images.

    voala
    Member

    @voala

    Hm.. this is really strange.
    Do your pages or posts have images in them? Are the images uploaded using media gallery? Located in wp-content/uploads/….. i mean or you use a different folder?

    21CB
    Member

    @21cb

    Yep, all images are in the uploads folders.

    voala
    Member

    @voala

    Give me the link to one of your pages.

    21CB
    Member

    @21cb

    threedogmoon
    Member

    @threedogmoon

    I am also having thumbnail related issues when working with one of my sites.

    When I put a link to a post into Facebook, it shows the Gravatar logo.
    So if I link to this post: http://www.casualvoyeur.com/hot-girls-kissing-videos — FB shows the Gravatar logo.

    When I put the home URL into Facebook, it shows video thumbnails from a specific post…

    So put in the home link in FBhttp://www.casualvoyeur.com and for some reason, Facebook pulls thumbnails from this post: http://www.casualvoyeur.com/hot-massage-youtube

    This is weird to say the least.

    21CB
    Member

    @21cb

    Voala – did you see the link I posted? I really appreciate your help.

    voala
    Member

    @voala

    Ok, let me ask you. From this page what image would you like to show on facebook post? The post itself has no image in it from what I can see.

    21CB
    Member

    @21cb

    Oh my apologies – perhaps that was not the best example. Although – could the featured image not come through as a thumbnail? The featured image I set for my posts appears on my front page with post description when I publish it.

    I am happy for any image from a given post to display – in the past you could cycle through them and choose a thumbnail on Facebook, I take it that may not be possible any more, although I can do it for links from different sites…

    voala
    Member

    @voala

    Ok. I did a little research on this matter.
    It seems that Facbook Publisher uses Open Graph protocol tags to scrap the information from post, like title, image, etc.. More information here: https://developers.facebook.com/docs/opengraph/

    First of all, i would recommend you to add a facebook like plugin to your website. For my website i use AddThis plugin. Very easy to configure and use (http://wordpress.org/extend/plugins/addthis/). This may solve the problem. If not, you can try adding the OG tags in the header.php page of your theme folder.

    Ex: (before the </head> tag)

    <meta property="og:title" content="The Rock"/>
        <meta property="og:type" content="movie"/>
        <meta property="og:url" content="http://www.imdb.com/title/tt0117500/"/>
        <meta property="og:image" content="http://ia.media-imdb.com/rock.jpg"/>
        <meta property="og:site_name" content="IMDb"/>
        <meta property="fb:admins" content="USER_ID"/>
        <meta property="og:description"
              content="A group of U.S. Marines, under command of
                       a renegade general, take over Alcatraz and
                       threaten San Francisco Bay with biological
                       weapons."/>

    Maybe this would work.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Facebook Thumbnail Issue. Really need some help.’ is closed to new replies.