WordPress.org

Support

Support » Plugins and Hacks » Exploit Scanner » Exploit Scanner errors

Exploit Scanner errors

  • Hi! I just installed the plugin and I get the following errors when trying to run a scan:

    Warning: array_slice() [function.array-slice]: The first argument should be an array in /home/somethin/public_html/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 498

    Warning: Invalid argument supplied for foreach() in /home/somethin/public_html/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 520

    And then it says Complete but the wheel keeps spinning.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jon Cave

    @duck_

    WordPress Dev

    Hey. Thanks for reporting.

    Would you be able to try out the development version of the scanner? I have added some code to catch the error and return some debug information. If you could try it out and paste back what it reports, please use pastie.org or another paste bin if the output is quite large. The output should just be put into the running box instead of the spinner.

    Development version available from http://wordpress.org/extend/plugins/exploit-scanner/download/ and here is a direct link to the zip file.

    The development version should be reported as 0.99.1 (if it’s not wait for an [half-an-]hour and try downloading it again) on the plugins page and can be installed by downloading the zip file and then going to Add New plugin in your dashboard and using the Upload option.

    Thanks again!

    I can try the development version tonight when I get home from work. I’ll get back with the errors then. 🙂

    I installed the development version and tried to run the scan, but it just says Files scanned: 0.. and the wheel spins. It’s been doing that for about 10 minutes. There’s no error output this time. I tried deactivating all other plugins, but the same thing happens.

    The strange thing is that I installed the development version locally, ran it, and there it works perfectly. The main difference is that locally I’m running 3.1 instead of 3.0.4.

    Ran into the same error:

    changed the domain name. 🙂

    Warning: array_slice() [function.array-slice]: The first argument should be an array in /nfs/c04/h02/mnt/62464/domains/yourdomain.org/html/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 498
    
    Warning: Invalid argument supplied for foreach() in /nfs/c04/h02/mnt/62464/domains/yourdomain.org/html/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 520
    Plugin Author Jon Cave

    @duck_

    WordPress Dev

    Would you be able to try out the development version (see details above) which should be version 0.99.2 now.

    Could you also tell me what other plugins you’re running? And any other details about your set up could be useful. It’s so frustrating that I can never reproduce this!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Exploit Scanner errors’ is closed to new replies.
Skip to toolbar