Support » Plugins and Hacks » Exhibit error

  • I’ve installed Exhibit and all was going well until I tried to post one of the images i had uploaded and I get an error:

    Warning: Invalid argument supplied for foreach() in /home/matandke/public_html/wp-content/plugins/exhibitimg/exhibit10i.php on line 310

    any ideas – using 1.5

Viewing 4 replies - 1 through 4 (of 4 total)
  • pcmanpa

    (@pcmanpa)

    I too have this error since upgrading to version 2.0 of WordPress.

    iand

    (@iand)

    Try changing line 311 from
    foreach($_POST['ex_caption'] as $index => $item)
    to
    foreach((array)$_POST['ex_caption'] as $index => $item)

    Not exactly sure how or why, but it wored for me.

    pcmanpa

    (@pcmanpa)

    That worked for me IanD. Thank you kindly.

    Thanks, Ian. Also worked for me.

    Suggestion: Exhibit is very popular but Owen is taking some time off, so these running fixes are piling up (and doubling up) in WordPress support (and on RedAlt).

    Does anyone else agree that it might make sense to create a topic that just summarises and cross references the various “fixes” – including those known now and those that we are yet to find 😉 I don’t know exactly how this would work, but I’ve made two essential fixes in the last 24 hours thanks to this Board & Google.

    Ted

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Exhibit error’ is closed to new replies.