Support » Plugin: EWWW Image Optimizer » exec()

  • Resolved aminsoltani

    (@aminsoltani)


    Hi

    I’m using php 7.3 and in php.ini, there no evidence about exec() but i get this error:

    EWWW Image Optimizer requires exec() to perform local compression. Your system administrator has disabled the exec() function, ask them to enable it.

    there is just these words in disable_functions:

    disable_functions = show_source, system, shell_exec, passthru, popen, proc_open

    what should i do ?
    is there anything else to do ?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Can you please copy the debug information from the Support tab of the settings page, and submit that via https://ewww.io/contact-us/
    Thanks!

    To find out what the EFFECTIVE setup of PHP is, use the function phpinfo(), as described here (if you’re on cPanel).

    Plugin Author nosilver4u

    (@nosilver4u)

    The phpinfo() function is very useful for this, should have mentioned that originally, thanks @galbaras
    It will also allow you to see what PHP configuration files are being used by your site. This plugin can also be of use for checking PHP configs: https://wordpress.org/plugins/wp-serverinfo/

    I have the same issue as @aminsoltani. Any WordPress installation with EWWW Image Optimizer installed started displaying the same error message two weeks ago. The php.ini on the dedicated server does not include an exec() exception.

    From debug log:

    EWWW IO version: 481.0
    WP version: 5.2.2
    PHP version: 70219
    libxml version: 20907
    max_execution_time: 200
    detected memory limit is: 268435456
    wp-content/ewww permissions: 0755
    ewww_image_optimizer_exec_check()
    exec seems to be disabled

    This is incorrect. exec() is NOT disabled.

    This might just be a coincidence. Run phpinfo(), as suggested above, and check for the EFFECTIVE settings.

    I have a sneaky suspicion that @aminsoltani found the answer there…

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.