WordPress.org

Support

Support » Plugins and Hacks » Hacks » eval() Error on Exec-PHP with INCLUDE and GET parameters

eval() Error on Exec-PHP with INCLUDE and GET parameters

  • Hello, WordPress is just great. But now I’m having a problem with the Exec-PHP plugin. Actually I think it’s a wordpress problem (or unknown behaviour to me), not a plugin problem.
    Usually Exce-PHP plugin just works fine, for example I can use a simple “include” as this:

    include ‘myprog.php’;

    but it’s not working when passing parameters to this included php file:

    include ‘myprog.php?page=feature&id=2’;

    this is strange. Here I get:
    Warning: include(myprog.php?page=feature&id=2) [function.include]: failed to open stream: No error in C:\xampp\htdocs\T2P-Wordpress\wp-content\plugins\exec-php\includes\runtime.php(42) : eval()’d code on line 16
    Warning: include() [function.include]: Failed opening ‘myprog.php?page=feature&id=2′ for inclusion (include_path=’.;C:\xampp\php\PEAR’) in C:\xampp\htdocs\T2P-Wordpress\wp-content\plugins\exec-php\includes\runtime.php(42) : eval()’d code on line 16

    Does someone have an idea why?
    Thanks
    hb

Viewing 1 replies (of 1 total)
  • Hello, I also tried with several others wp php plugins.
    All are returning the same error. So this has nothing to do with the plugings. It must be something special within wordpress itself.
    Any idea?
    Regards
    hp

Viewing 1 replies (of 1 total)
  • The topic ‘eval() Error on Exec-PHP with INCLUDE and GET parameters’ is closed to new replies.
Skip to toolbar