Support » Plugin: Search Regex » Error with WP 3.5

  • Hello, this plugin has worked perfectly for me until I upgraded WP to 3.5. Now when I try to do a Replace I get this error message at the top of the screen:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/xxxxx/public_html/wp-content/plugins/search-regex/searches/post_content.php on line 10 and defined in /home/xxxxx/public_html/wp-includes/wp-db.php on line 990

    I never got this error message until I updated to 3.5.

    Any ideas what this means? Is there any known incompatibility with WP 3.5? Is a new version of this plugin going to be produced? Thanks!

    http://wordpress.org/extend/plugins/search-regex/

Viewing 1 replies (of 1 total)
  • Hey,

    I also got this problem after upgrading WP to 3.5.

    I found some solutions, but with every plugin you need to edit this one line differently:

    //OLD:
    $wpdb->prepare( "SELECT * FROM some_table WHERE ID = $id AND name = $name" );
    //NEW:
    $wpdb->prepare( "SELECT * FROM some_table WHERE ID = %d AND name = %s", $id, $name );

    I don’t have idea how to edit this…

Viewing 1 replies (of 1 total)
  • The topic ‘Error with WP 3.5’ is closed to new replies.