Support » Plugin: Simply Schedule Appointments » Error upon activation

  • Resolved chania06

    (@chania06)


    Аn error occurred while activating the plugin – Fatal error: Can’t use method return value in write context in /wp-content/plugins/simply-schedule-appointments/includes/lib/td-util/extended-cpts/src/class-extended-cpt-admin.php on line 682

    • This topic was modified 6 months, 1 week ago by  chania06.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author croixhaug

    (@croixhaug)

    Hi there, sorry you’re having trouble with our plugin. Can you tell us what version of php you are running on your site? (There are also plugins that can tell you this, just search the plugin directory for “phpinfo”)

    Thanks,
    Nathan

    Plugin Contributor Natalie MacLees

    (@nataliemac)

    Hello @chania06,

    Did you still need help getting this sorted out?

    Hy,
    I have a similar problem during activation.

    syntax error at /simply-schedule-appointments/includes/lib/td-util/extended-cpts/functions.php on line 59

    Thanks
    A.

    Plugin Author croixhaug

    (@croixhaug)

    Hi @doctor17, is there any more information on screen associated with that error? And do you happen to know what version of PHP you are running?

    Thanks,
    Nathan

    Error is:
    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in wp-content/plugins/simply-schedule-appointments/includes/lib/td-util/extended-cpts/functions.php on line 59

    php version is 5.3.3

    Thanks,
    Antonio

    Plugin Author croixhaug

    (@croixhaug)

    Thank you @doctor17, we will look at the compatibility on PHP 5.3.3.

    PHP 5.6 is about to reach end of life, so for security, it would be best to update to PHP 7.0 (and it happens to be a lot faster too) Your host should be able to upgrade you to 7.0, or at least 5.6, pretty easily.

    I believe SSA should work on PHP 5.3 still, so we will see about releasing a fix for that

    Thanks,
    Nathan

    Plugin Author croixhaug

    (@croixhaug)

    Hi @doctor17, I found the source of this error, our code that checks for your server’s PHP version wasn’t running. Simply Schedule Appointments supports PHP 5.6+

    PHP 5.6 is actually going to be insecure (no longer updated with security patches by the PHP project) within a few months.

    Web hosts are upgrading their servers to 7.0, 7.1, 7.2 – if you send an email to your web host, they’ll probably be happy to upgrade you. 7.0 can require some older plugins to break, but you should be able to upgrade to at least PHP 5.6 with very little risk.

    Simply Schedule Appointments uses some code libraries that require PHP 5.6, so unfortunately we can’t support an earlier version.

    We just pushed a new release (v1.2.1.7) that checks compatibility and shows a more informative error message instead of the one you saw. Thanks for letting us know!

    Best,
    Nathan

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.