WordPress.org

Support

Support » Plugins and Hacks » Edge Suite » [Resolved] Error Uploading

[Resolved] Error Uploading

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author ti2m

    @ti2m

    Hi,
    this means the uploaded file could not be moved into edge_suite/tmp. Does the tmp directory have 777 as well? Was the tmp directory created?

    Hi,
    just checked and there is no edge_suite/tmp directory, and yes the whole file structure/directory is on 777, Im gonna manually try and create the edge_suite/tmp directory and see if that fixes the issue.

    Hi
    I manually created the edge_suite/tmp directory but still not luck. 🙁

    Plugin Author ti2m

    @ti2m

    Hi,
    if the tmp directory isn’t created automatically then the plugin also won’t be able to create other necessary folders. What really irritates me is that EdgeSuite didn’t detect that the tmp dir wasn’t there or that it couldn’t create it. Multiple directory and write tests run before copying the files and I don’t get how these tests do not fail.

    Are you using the latest version 0.4? Can you please delete the whole edge_suite folder, recreate it and then set it to 777. Any idea if PHP might be running in safe mode?

    Hi,
    I have WordPress Version 3.4.2 installed which is the latest version available on the site (http://wordpress.org/download/release-archive/), I have no idea if the php is set on safe mode either.

    Plugin Author ti2m

    @ti2m

    Hi,
    ok, I’ll check on the safe mode option and add some more tests and commit it to the dev branch. I’ll sent you the link, hopefully that will give us a clue on what’s going on. In the meantime, what hoster are you on? Then I can check there forums if someone else is having permission issues, that usually helps a lot.

    Thanks

    Plugin Author ti2m

    @ti2m

    It gets stranger, I put my PHP into safe mode and I directly get the message from Edge Suite: “Unable to create directory XXX. Is its parent directory writable by the server?” But I assume you don’t get that message?

    Even in normal mode Edge Suite always checks and tries to create wp-content/uploads/edge_suite/project on the manage page and if it can’t you get an error message. Do you really not get any other error messages? Anything in the red error box on the manage Edge Suite page?

    It’s like all the checks are being ignored and it only crashes when you the server tries to copy the uploaded file. Right now I don’t see how that would be possible.

    Hi, sorry for the late reply.

    I dont get that error, I only get a “Sorry, there was a problem uploading your file. You may need to check your folder permissions or other server settings” error, I use
    Hertzner for Hosting and Ive never had previous issues with them.

    Plugin Author ti2m

    @ti2m

    Hertzner, really? That makes it even worse as I never had problems with them either 😉

    Ok, I’ll check the code again, add some more checks to the dev branch and let you know. Maybe you can give it a try then

    Okay, just let me know when.

    Plugin Author ti2m

    @ti2m

    Hi,
    I’ve added a couple more checks.

    Please uninstall the whole plugin on your site and delete all edge suite directories, even the uploads/edge_suite dir, I want to see if the plugin can create anything at all.

    Get the trunk plugin version here:
    http://downloads.wordpress.org/plugin/edge-suite.zip

    Install as usual. Please let me know which directories were created and if you get any error messages at all. All checks should be done even before you try to upload anything.

    jmorato

    @jmorato

    Hi Timm, I posted this in another topic….

    Hi,

    I just trying the Edge Suit for wordpress in my own computer with MoWes…I upload the .oam file and doesn’t work the upload action. My message error is:

    Tmp test file could not be written to C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite

    One more thing; the /uploads/edge_suite folder or /uploads folder haven,t been created during de edge_suite installation inside /wp-content folder.

    Could you help me?

    I,ve tried to assign the whole control to /wp-content folder but doesn`t work…

    I downloaded de zip you bring above and installed….now the error message is different and similar:

    Edge Suite: Unable to create directory project directory (C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite/project). Is its parent directory writable by the server?
    Tmp test file could not be written to C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite.

    I can wait your answer because I go to bed….

    It doesn,t work yet for me but It,s a great plugin…thanks a lot.

    Plugin Author ti2m

    @ti2m

    Hi jmorato,

    the project directory path is a combination of the absolute path wordpress (or the index.php) sits in (which is C:\MoWes\www\wordpress/ in your case) and the upload directory, usually wp-content/uploads (a path RELATIVE to the index.php!). You seem to have defined an ABSOLUTE upload directory:
    D:\wos1\1\www\wordpress/wp-content/uploads/

    That creates C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite as a project path, which of course can’t work.

    I’m not sure that absolute path works for your upload directory at all in wordpress. Did you set the path or did it come with MoWes? Are you able to upload images or anything. Especially on windows I’can see how your external upload dir could be linked into the main wordpress dir. Maybe you can try changing the upload dir to a relative path (Settings > Media >Uploading Files), or just delete the path and wp will use the default relative path. Or do you have the “Full URL path to files” option set as well in this section?

    Cheers, Timm

    jmorato

    @jmorato

    Thanks a lot Timm!!!

    It was as easy as you told me! I,ve changed D:\wos1\1\www\wordpress/wp-content/uploads/ by the default wordpress value (wp-content/uploads) in Settings > Media >Uploading Files and it works perfect!
    For now I,ve only chosen the composition in Edge Suite/settings/blog page composition and it works perfect; it appears at the home page….

    One more question…is it possible to know what was edited to make it works? It’s nice to see that it works but also is important where and what code file was edited and understand the way it works.

    Last question…In my case I done what I,ve just written; but Is there an exemple, web/video link or other topic
    of the snippet option “if(function_exists(‘edge_suite_view’)){echo edge_suite_view();}”
    and “[edge_animation id=”number ID compposition”]” (inserted in a post) you told in your installation guide?

    Thanks a lot.

    PD: I,ve just voted it works 😉

    Plugin Author ti2m

    @ti2m

    Hi jmorato,
    glad to hear it works now. Have you seen the linked tutorial on the plugin page:

    http://edgedocks.com/content/edge-suite-integrate-edge-animate-wordpress

    That’s the most detailed tutorial there is. If you want to know what exactly is going on under the hood you have to check the code itself, I tried to document it fairly well. I don’t think most users are interested in which paths are altered, which loading function calls are redirected… That’s basically what the plugin is for 😉

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Error Uploading’ is closed to new replies.
Skip to toolbar