Support » Plugin: Subpages Extended » ERROR php 7

  • Resolved toto

    (@toto)


    Warning: Declaration of Shailan_Walker_Page::start_lvl(&$output, $depth) should be compatible with Walker::start_lvl(&$output, $depth = 0, $args = Array) in /home/tyhru/public_html/testserv/wp-content/plugins/subpages-extended/class-shailan-walker-page.php on line 65

    I use php 7 how to fix it?

    https://wordpress.org/plugins/subpages-extended/

Viewing 6 replies - 1 through 6 (of 6 total)
  • I fixed them by this changes in class-shailan-walker-page.php

    line 14:
    function start_lvl(&$output, $depth = 0, $args = Array()) {

    line: 19
    function end_lvl(&$output, $depth = 0, $args = Array()) {

    line: 24
    function start_el(&$output, $page, $depth = 0, $args = array(), $current_page = 0) {

    line 62:
    function end_el(&$output, $page, $depth = 0, $args = Array()) {

    you can update the plugin

    This solves the errors.

    Fixed for me too, thanks!

    We’re still seeing these errors in 1.3.6 on PHP7:

    Warning: Declaration of Shailan_Walker_Page::start_lvl(&$output, $depth) should be compatible with Walker::start_lvl(&$output, $depth = 0, $args = Array) in wp-content\plugins\subpages-extended\class-shailan-walker-page.php on line 65
    
    Warning: Declaration of Shailan_Walker_Page::end_lvl(&$output, $depth) should be compatible with Walker::end_lvl(&$output, $depth = 0, $args = Array) in wp-content\plugins\subpages-extended\class-shailan-walker-page.php on line 65
    
    Warning: Declaration of Shailan_Walker_Page::start_el(&$output, $page, $depth, $args, $current_page) should be compatible with Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in wp-content\plugins\subpages-extended\class-shailan-walker-page.php on line 65
    
    Warning: Declaration of Shailan_Walker_Page::end_el(&$output, $page, $depth) should be compatible with Walker::end_el(&$output, $object, $depth = 0, $args = Array) in wp-content\plugins\subpages-extended\class-shailan-walker-page.php on line 65

    Additionally the following deprecated message is thrown:

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; shailan_SubpagesWidget has a deprecated constructor in wp-content\plugins\subpages-extended\subpages-widget.php on line 34

    • This reply was modified 1 year, 4 months ago by  Louis Wolf. Reason: typo

    The changes proposed by @toto helped to fix the warnings, but now I get these:

    [20-Aug-2017 11:11:16 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; shailan_SubpagesWidget has a deprecated constructor in /var/www/vhosts/cable4.de/httpdocs/2017/wp-content/plugins/subpages-extended/subpages-widget.php on line 34
    [20-Aug-2017 11:11:16 UTC] PHP Notice:  Die verwendete Konstruktor-Methode für WP_Widget in shailan_SubpagesWidget ist seit Version 4.3.0 <strong>veraltet</strong>! Verwende stattdessen <pre>__construct()</pre>. in /var/www/vhosts/cable4.de/httpdocs/2017/wp-includes/functions.php on line 3894
    [20-Aug-2017 11:11:18 UTC] PHP Notice:  Die verwendete Konstruktor-Methode für WP_Widget in shailan_SubpagesWidget ist seit Version 4.3.0 <strong>veraltet</strong>! Verwende stattdessen <pre>__construct()</pre>. in /var/www/vhosts/cable4.de/httpdocs/2017/wp-includes/functions.php on line 3894
    Plugin Author Metin Saylan

    (@mattsay)

    fixed those errors with version 1.5

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ERROR php 7’ is closed to new replies.