Support » Plugin: SVG Support » Error on plugin settings page

  • Resolved super powered

    (@super-powered)


    Error: Notice: Uninitialized string offset: 0 in /vagrant/wordpress/wp-content/plugins/svg-support/admin/svgs-settings-page.php on line 95

    Shows up right after “Restrict To Administrators?”

    
    1	0.0037	361176	{main}( )	.../options-general.php:0
    2	0.0042	361848	require_once( '/vagrant/wordpress/wp-admin/admin.php' )	.../options-general.php:10
    3	0.2139	2804288	do_action( )	.../admin.php:222
    4	0.2139	2804664	WP_Hook->do_action( )	.../plugin.php:453
    5	0.2139	2804664	WP_Hook->apply_filters( )	.../class-wp-hook.php:323
    6	0.2139	2805792	bodhi_svg_support_settings_page( )	.../class-wp-hook.php:298
    7	0.2208	2807000	require( '/vagrant/wordpress/wp-content/plugins/svg-support/admin/svgs-settings-page.php' )	.../admin-init.php:38
    
    
    ( ! ) Notice: Uninitialized string offset: 0 in /vagrant/wordpress/wp-content/plugins/svg-support/admin/svgs-settings-page.php on line 95
    Call Stack
    #	Time	Memory	Function	Location
    1	0.0037	361176	{main}( )	.../options-general.php:0
    2	0.0042	361848	require_once( '/vagrant/wordpress/wp-admin/admin.php' )	.../options-general.php:10
    3	0.2139	2804288	do_action( )	.../admin.php:222
    4	0.2139	2804664	WP_Hook->do_action( )	.../plugin.php:453
    5	0.2139	2804664	WP_Hook->apply_filters( )	.../class-wp-hook.php:323
    6	0.2139	2805792	bodhi_svg_support_settings_page( )	.../class-wp-hook.php:298
    7	0.2208	2807000	require( '/vagrant/wordpress/wp-content/plugins/svg-support/admin/svgs-settings-page.php' )	.../admin-init.php:38
    

    Theme: Twenty Seventeen, with no changes.

    Plugin Version: 2.3.5

    No other plugins activated.

    I had gotten a strange warning when I initially activated it, but am unable to reproduce.

    • This topic was modified 2 years, 10 months ago by super powered.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Looking at the file in question the error is being thrown from this variable:

    value="<?php echo $bodhi_svgs_options['css_target'];

    in the “CSS Class to target” Option

    Plugin Author Benbodhi

    (@benbodhi)

    Hi there,
    That’s really strange, I would think more people would have an error like that.
    I’ll do my best to test for it and see what I can find out, but I’ve just had a bad accident today and I’m in hospital waiting for surgery… So I might be a few days unfortunately.

    Thanks for your patience and I’ll let you know asap.

    Plugin Author Benbodhi

    (@benbodhi)

    I haven’t been able to reproduce this.
    Could you please explain more about your environment and steps to reproduce?
    Or you could send me login details to take a look wp@benbodhi.com

    Sorry for the late reply, was out for the weekend.

    I was able to fix it by just adding a quick isset() if statement to the line before it echoes.

    As for the error on activation, I have been able to reproduce it on a second site now and have copied it below.

    The error:
    “The plugin generated 214 characters of <b>unexpected output</b> during activation. If you notice “Headers already sent” messages, problems with syndication feeds of other issues, try deactivating or removing this plugin.”

    The new site also has the same issue with the “CSS Class to target” when not initially set. However, after setting it “test” the error goes away, and then stays away even when set back to blank.

    I assume there’s something happening on activation causing that initial value not to be put into the array.

    The setups are pretty basic. Both had just ACF PRO, Yoast and Wordfence installed with pretty bread and butter custom themes.
    One threw the error on a vagrantpress box, the other on a live godaddy server.

    Worth noting that after the initial error message, I’m unable to reproduce it again on either of the sites. Even after deactivating/reactivating.

    • This reply was modified 2 years, 10 months ago by super powered.
    • This reply was modified 2 years, 10 months ago by super powered.
    Plugin Author Benbodhi

    (@benbodhi)

    Hi @super-powered

    I’ll take a look into this and let you know.
    Unfortunately, I’m in hospital with a broken leg and a bunch of ribs.. but I will get to it asap.

    Thanks for your support!

    Plugin Author Benbodhi

    (@benbodhi)

    I believe I have fixed both of these issues in version 2.3.6

    Thanks again for your support and for pointing these errors out. I will mark this thread as resolved now. Please let me know if you do still have these errors and I will switch back and fix if need be.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error on plugin settings page’ is closed to new replies.