Support » Plugin: KaTeX » error on installation

  • Resolved meinfach2

    (@meinfach2)


    Hi, working with WP 5.1.1, at installazion I get following warnings:

    Warning: Constants may only evaluate to scalar values in /membri/meinfach/wp-content/plugins/katex/katex.php on line 38

    Warning: Illegal string offset ‘katex_latex_shortcode_setting’ in /membri/meinfach/wp-content/plugins/katex/scripts/shortcode.php on line 28

    Warning: Illegal string offset ‘katex_jsdelivr_setting’ in /membri/meinfach/wp-content/plugins/katex/scripts/resource.php on line 32

    Not able to use KATEX in gutemberg blocks.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,
    I disabled/enabled and uninstalled/installed but warnings are there.
    I can add KATEX blocks and looks working despite what I wrote in first message.
    Problem is only warnings that are always present in editor and are quite annoying.

    Plugin Author Thomas Churchman

    (@beskhue)

    Thanks for the issue report. Could you indicate which version of PHP you encounter this on?

    meinfach2

    (@meinfach2)

    Hi Thomas,
    the version of PHP is 5.6.40
    it is provided by the hosting service, I cannot upgrade it to a more recent one.

    Plugin Author Thomas Churchman

    (@beskhue)

    Thank you; I’ve released version 1.0.3 that fixes this issue for PHP 5.

    meinfach2

    (@meinfach2)

    Thanks Thomas, I can confirm that problem is resolved

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.