Support » Plugin: CKEditor WYSIWYG for Gravity Forms » Error message: Warning: array_key_exists() expects parameter 2 to be array…

  • Resolved psiginc

    (@psiginc)


    Once the user completes a registration form, on Firefox they receive this error message: Warning: array_key_exists() expects parameter 2 to be array, null given in /home2/psiginc/public_html/wp-content/plugins/gravity-forms-wysiwyg-ckeditor/gf_wysiwyg_ckeditor_plugin.php on line 820

    The user the mentioned the error message was using Firefox version 38.4.0.

    All of our wordpress plug ins, add ons and systems are up to date.

    How do I correct this error? I’ve tried uninstalling and reinstalling the plug in.

    https://wordpress.org/plugins/gravity-forms-wysiwyg-ckeditor/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ovann86

    (@ovann86)

    Hey,

    I don’t have time right now to look at the specifics of that error message, but I can say that it seems to be happening for everyone and with no real affect (data is submitted fine, page loads for user).

    The difference is, you’re seeing the error message because you have debug mode turned on. Without debug mode turned on there messages are not displayed to users.

    I will look at the cause of the error, hopefully in the next 24 hours, but I highly suggest you turn off debug mode if it’s a production website (not a test website).

    To turn it off you’ll need access to the WordPress files on your web server, for example using FTP or your websites cpanel. You will need to edit your wp-config.php file, changing ‘debug_mode’ to ‘false’.

    https://codex.wordpress.org/Debugging_in_WordPress

    Hi Adrian –

    I’m experiencing the same error (it’s repeated multiple times on the page, above the confirmation message), and I do have debug_mode set to false. Do you have any other options for a quick fix, just to prevent the error from appearing on the page?

    Thanks.

    Plugin Author ovann86

    (@ovann86)

    Hey,

    I have released version 1.8.1 which uses a different method to check the variable – I hope it won’t cause any error messages on submitting like array_key_exists() was.

    Could you update to version 1.8.1 and let me know how it goes?

    Thanks for making this fix… I updated the plugin, and the errors went away.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error message: Warning: array_key_exists() expects parameter 2 to be array…’ is closed to new replies.