Support » Plugin: Simple Twitter Tweets » Error Message

  • Resolved jennyfogarty


    Hi Guys,

    Installed the plugin perfectly, and it worked for a second but then I got this error:

    Invalid argument supplied for foreach() in /home/j53207/public_html/ on line 391

    Can you tell me what I might be doing wrong?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Planet Interactive


    The line number you refer too references the screen name variable.

    Please check your widget settings that the screen name has been successfully saved.

    FYI, at the line number you reference the code has already passed the check for the tweets and is in display mode (iteration) – the error (not seen before) uses the twitter screen name or the name variable as set (failsafe) ?

    Please check you have all setup correctly per the instructions here

    What are your settings?

    I am having this problem too. The plugin worked correctly for a week or so after installation, but now it’s returning the same error message as the original post.

    Was there a solution to this?

    Plugin Author Planet Interactive


    Hi timkeay

    Please check the settings from the previous response posted. Jenny never responded as you can see so I guess she/they either found the solution in the text or moved on – who can say.

    Please do check you do not have a space at the beginning or end of any of the input fields of the widget as this has been known to cause issues.

    Hope that helps

    Hi. Thanks for your response. I checked all the plugin settings and everything was fine – no spaces, etc. I then changed the Twitter username to my own, refreshed the front end and it displayed my own tweets until I refreshed the page again and then they disappeared. I went into the Twitter application settings for my client’s feed, reset/refreshed the keys and used the new values and it now works again.

    I’ll reply to this thread again if things stop working.

    Thanks again for getting back to me.

    Hi. The Plugin was working fine for a few days, now it’s stopped again and is displaying the following error messages:

    Warning: Invalid argument supplied for foreach() in /xxx/wp-content/plugins/simple-twitter-tweets/simple-twitter-tweets.php on line 391

    I’m going to try another tweets plugin in the meantime, but it’d be interesting to figure this one out if the above gives you any clues?



    Hello, I was having the same problem but found out that it only happens when I have the word default in the tweet. Once I deleted the tweet containing that word, it went back to normal.

    Plugin Author Planet Interactive


    Fixed – try 3.0

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error Message’ is closed to new replies.