WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Error in WP 3.5

[Resolved] Error in WP 3.5

  • This is in WP 3.5. (Not MultiSite)

    Gives the following error:
    Missing argument 2 for wpdb::prepare(), called in \wp-content\plugins\cpt-onomies\cpt_onomy.php on line 260 and defined in \wp-includes\wp-db.php on line 990

    Looks like it is missing a second argument.

    I’m working with another plugin author. Same thing. Everything is fine in WP 3.4.2 but getting errors in WP 3.5.

    Let me know if you need more info.

    Ron

    http://wordpress.org/extend/plugins/cpt-onomies/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Rachel, this should help:

    Changeset 22429
    Timestamp:
    11/07/12 19:30:59 (3 weeks ago)
    Author:
    nacin
    Message:

    Enforce a minimum of two arguments for wpdb::prepare(). The first argument is the query (or fragment thereof), which is required. Additional arguments are values to substitute into placeholders.

    This will generate E_WARNINGs for insufficient arguments when prepare() is called with no additional arguments. This should discourage improper uses of prepare() under the guise of safely running a query.

    props xknown. fixes #22262.

    It looks like they are forcing wpdb to have a second argument.

    Ron

    Plugin Author Rachel Carden

    @bamadesigner

    Thanks Ron!! I’ll get it all fixed up for the next update.

    Plugin Author Rachel Carden

    @bamadesigner

    I’ve got this all fixed for the next update! Thanks for the heads up!

    Great! Thanks Rachel!

    I’m looking forward to it.

    Ron

    Wouldn’t it be easy to simply add some code to line 990 in wp-db.php?

    function prepare( $query, $args) {

    Becomes

    function prepare( $query, $args = "" ) {

    Hi there.
    First things first, thanks for the nice plugin !

    Now, WP 3.5 has gone public and I need a fix as the update to wp-db broke quite a bunch of functionalities of my current project.

    Do you plan to release the update anytime soon ?

    Cheers !

    p.

    Plugin Author Rachel Carden

    @bamadesigner

    I hope to push out the update tomorrow!

    That would be perfect !

    Thanks for the quick answer ! Keep up the good work !

    Thank u Rachel !

    I going to make a fix quick in waiting the update tomorow.

    B Regards,

    I’m also getting the error on line 1348 of cpt_onomy.php.

    You can just add “, NULL” to the end of the wpdb::prepare() statement.

    Ross

    Plugin Author Rachel Carden

    @bamadesigner

    CPT-onomies 1.2 is out and should take care of this. Thanks!

    thanks !

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Error in WP 3.5’ is closed to new replies.