Support » Fixing WordPress » Error establishing a database connection

  • I’m having intermittent problems displaying my site in a browser. It comes up with the message’Error establishing a database connection’.

    So far it keeps coming back after a minute or so. It’s happening as I edit my theme (inove), especially when I do anything with the sidebar widgets.

    Is this something someone else has experienced? Is there something I’m doing wrong? Could it be my hosting company having problems?

    The URL is http://www.themusicophile.com if that helps at all.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • If it’s intermittent, then it’s probably your hosting company…server and/or db crashing or dropping the connection.

    EDIT: I see a banner in your sidebar that reads:

    “The servers which host this website/blog are powered by 100% wind energy”

    Maybe the wind is a little erratic 😉

    server and/or db crashing or dropping the connection.

    as figaro points out
    use the host’s phpmyadmin to run a “repair” on the wp_options table in the database

    I’ve run the repair as samboll suggested, not sure whether it’s done anything though, haven’t had the problem since, but it was intermittent anyway so who knows. Thank you for the quick replies.

    Maybe it is just the wind figaro, these things happen to me. I was cycling the other day and got three punctures in less than an hour. I guess it’s just the price you pay for being green…

    I was cycling the other day and got three punctures in less than an hour.

    I hear that…in 94 I rode my bike, along with three of my running club buddies, from Lands-end to John O’Groats, about 1,100 miles, loaded with camping gear, and never got a single puncture. I ride 10 miles on paved road now and seem to get one every other time I go out 😉 Go figure…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error establishing a database connection’ is closed to new replies.