Support » Plugin: Sitemap Generator » Error code

Viewing 1 replies (of 1 total)
  • Plugin Author Marco Beierer

    (@mbsec)

    Hi Paul,

    Thank you for trying the Sitemap Generator.

    This issue is most probably caused by an outdated cURL or OpenSSL version. Both libraries need to support SNI. cURL supports SNI from version 7.18.1 (published 2008) and OpenSSL from version 0.9.8f (published 2007) or later.

    If you are using PHP 5.3 or earlier, the issue could most probably be fixed by upgrading to a more recent PHP version. But be aware that this could have side effects if a plugin is not compatible with newer PHP versions. However plugins that are still maintained should be compatible with current PHP versions.

    If you are using an up to date PHP version, it could be that PHP is compiled against outdated versions of cURL or OpenSSL. In this case, may you check which versions of these libraries you are using? You may could do this in your hosters control panel. If not, phpinfo() would output the versions. Let me know if you need help with this. Normally such old versions of these libraries are not used on purpose and the hoster would fix this, if he knows about it.

    Best regards,
    Marco

Viewing 1 replies (of 1 total)
  • The topic ‘Error code’ is closed to new replies.