WordPress.org

Forums

Rotating Tweets (Twitter widget and shortcode)
[resolved] Error Code: (7 posts)

  1. erica_pro
    Member
    Posted 2 years ago #

    I just installed and created my twitter app today. I triple checked all my codes and they are correct.

    I am getting this error code when Verify SSL connection to Twitter is set on YES:

    "error message received from Twitter: "couldn't connect to host. Please check your API key, secret, token and secret token on the Twitter website."

    I am getting this error code when Verify SSL connection to Twitter is set on NO:

    "Error message received from Twitter: connect() timed out!. Please check your API key, secret, token and secret token on the Twitter website."

    What can I do to remedy this?

    Thanks for your help.

    http://wordpress.org/extend/plugins/rotatingtweets/

  2. Martin Tod
    Member
    Plugin Author

    Posted 2 years ago #

    This message means that WordPress isn't able to connect to Twitter.

    Is your server connected to the internet?

    If so, try installing the Core Control plug-in and disabling cURL. You can read more about the problem via this support page.

  3. erica_pro
    Member
    Posted 2 years ago #

    Hello Martin,

    Yes, my server is connected to the internet.

    I just updated to wordpress 3.5.2 and the Rotating Tweets plugin has been updated.

    I installed the Core Control plugin and disabled the cURL, and the plugin still does not work. I get the same error messages in the setup page, and on the widget the following message is showing: Problem retrieving data from Twitter

  4. Martin Tod
    Member
    Plugin Author

    Posted 2 years ago #

    The problem here is that your server is not connecting to the internet in a way that WordPress can use to pick up information from other sites. (That's any bit of WordPress, not just Rotating Tweets).

    One option might be to give it more time by increasing the timeout in lib/wp_twitteroauth.php on line 28, for example, by changing:

    public $timeout = 3;

    to

    public $timeout = 10;

    to see if that solves anything - but I suspect the problem is some kind of server setting.

    If you're technically minded, this post might be helpful.

  5. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    The latest development version of the script enables you to change the timeout. If you go to the rotating tweets settings page and increase the timeout to 7 seconds, does that solve the problem?

  6. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I've added some extra functions to the settings page that should help you fix this.

    If you need further diagnostics, I suggest setting changing the WP_DEBUG line in your wp-config.php file to:

    define('WP_DEBUG', true);

    and you will get the diagnostics you need as comments in the HTML of the page.

  7. adch
    Member
    Posted 1 year ago #

    Hi there, does the plugin function on localhost?
    I have installed it local and i am getting this error at "Rotating Tweets: Twitter API settings" page:

    "Error message received from WordPress: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed. Please check your connection settings."

    I also installed the Dev Version but still the same error!
    I am facing the same problem with erica_pro?

    Thanks is advance

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Rotating Tweets (Twitter widget and shortcode)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic