WordPress.org

Support

Support » Plugins and Hacks » BackWPup - WordPress Backup Plugin » ERROR: Can not add " " to zip archive!

ERROR: Can not add " " to zip archive!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Daniel Hüsken

    @danielhuesken

    The problem ist i must find out how many files can open at the same time an the most hoster. More files open results in better preformance. I have reduced the number to next update.

    Same happens to me, but I also have more problems, so it looks like this:

    ERROR: Can not add ” ” to zip archive!
    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    ERROR:
    ZipArchive returns status: (ER_DELETED) Entry has been deleted

    the same problem:
    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    and can not upload archives to SugarSync and Dropbox

    Probably same problem. This is on HostGator if that helps:

    [10-Mar-2013 06:36:04] Compression method is ZipArchive
    [10-Mar-2013 07:37:22] WARNING: Job restart due to inactivity for more than 5 minutes.
    [10-Mar-2013 07:37:22] 2. Trying to create backup archive …
    [10-Mar-2013 07:37:22] Compression method is ZipArchive
    [10-Mar-2013 07:37:22] ERROR: Can not add "wp-content/plugins/backwpup/sdk/Aws/Aws/Route53/Enum/" to zip archive!
    [10-Mar-2013 07:38:20] Backup archive created.

    We are still getting this with BackWPup 3.06.

    The files it fails on seem random – different ones each time.

    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    [17-Mar-2013 15:57:04] ERROR: Cannot add "wp-includes/SimplePie/Content/" to zip archive!
    [17-Mar-2013 15:57:04] ERROR: Cannot add "wp-includes/SimplePie/Decode/" to zip archive!
    [17-Mar-2013 15:57:04] ERROR: Cannot add "wp-includes/SimplePie/XML/" to zip archive!

    Still having the same problem. Can anyone help???

    ERROR: Can not add " " to zip archive!
    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    Caspar

    @friendlyghost

    Hi everyone,

    the issue here doesn’t seem to be the errors, but the preceding warning. Whenever you see a warning like WARNING: Job restart due to inactivity for more than 5 minutes., it has to do with a timeout during archive creation. The timeout is most likely to be caused by limitations on script execution set by the hosting company. Those can largely vary from host to host, so it is almost impossible to define a preset in the plugin that works for everyone.

    Therefore since BackWPup 3.0.6 there’s an option labeled Restart on archive creation in BackWPup->Settings->Jobs. Here you can manually set a number of x Megabytes BackWPup will add to an archive and then pause before adding another x MBs to the same archive. That way we try to avoid for the backup process to be canceled server-side because of a timeout for script execution.

    What you can do is:

    • Test out (trial/error) the number of MB that works for your server.
    • If that doesn’t work for you, split up a backup job into smaller backups (i.e. an extra job for /uploads).

    Splitting up large backup jobs into smaller ones might be a good idea anyway if your site contains a lot of uploaded files.

    I’m using backup option to Dropbox, and after that 3 errors I still find my backup in my Dropbox folder. So is that only like warning and everything is fine or I need to do something about it?

    Thanks

    1) This did not happen before 3.0 release
    2) It is happening on very small backups 15mb-50mb
    3) Only happens with zip, not TarGz
    4) we have made no other changes, just upgraded your plugin

    Hi all, try the solution posted on this thread. It might fix your issue.

    Kind regards

    I tryed BU today, and it works with 2 warnings.

    WARNING: No tables to dump.
    WARNING: Job restart due to inactivity for more than 5 minutes.

    Is that allright, or I need to concern about something?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘ERROR: Can not add " " to zip archive!’ is closed to new replies.
Skip to toolbar