Support » Plugin: Footnotes for WordPress » Error After Upgrade to Version 2016.1213

  • Resolved aa_haq

    (@aa_haq)


    It’s an error occured in my website after upgraded to Version 2016.1213. The message is:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /home/MYUSERNAME/public_html/wp-content/plugins/footnotes-for-wordpress/wp-footnotes.php on line 154

    Please fix it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Error on your website, http://projects.radgeek.com/wp-footnotes.php , it is also certainly due to an error on that line.

    Your page said:
    The projects.radgeek.com page isn’t working

    projects.radgeek.com is currently unable to handle this request.
    HTTP ERROR 500

    Looks like use of PHP 5.4+ short array syntax. I just had this error, my client is on PHP 5.3. I’ve patched the plugin but obviously the longer-term solution is upgrading PHP.

    Plugin Author C. Johnson

    (@radgeek)

    Hi @aa_haq, sorry you ran into this problem. The explanation that @gyrus suggests above is correct. I put out new release of the plugin, 2016.1230, which eliminates the use of short array syntax and so preserves backward-compatibility with very old versions of PHP (>=5.2.4, <5.4). You should be able to fix the problem by downloading the latest release. Let me know if it works for you.

    Ok @radgeek, version 2016.1230 is working for me now.
    Thanks 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error After Upgrade to Version 2016.1213’ is closed to new replies.