Support » Plugin: Custom Website Data » Error on activation

  • Resolved cancrexo

    (@cancrexo)


    Hi there
    After trying this awesome plugin on a local server, i tried to use it on a remote server, but every time i try to activate it, it throws the same fatal error:

    Fatal error: Uncaught exception 'ReflectionException' with message 'Class Cwd\Utility does not have a constructor, so you cannot pass any constructor arguments' in /home/sitename/www/wp-content/plugins/simple-custom-website-data/custom-website-data.php:202 Stack trace: #0 /home/sitename/www/wp-content/plugins/simple-custom-website-data/custom-website-data.php(202): ReflectionClass->newInstanceArgs(Array) #1 /home/sitename/www/wp-content/plugins/simple-custom-website-data/custom-website-data.php(26): CustomWebsiteData->autoLoadClasses() #2 /home/sitename/www/wp-content/plugins/simple-custom-website-data/custom-website-data.php(251): CustomWebsiteData->__construct() #3 /home/sitename/www/wp-admin/plugins.php(151): include('/home/sitename/w...') #4 /home/sitename/www/wp-admin/plugins.php(153): plugin_sandbox_scrape('simple-custom-w...') #5 {main} thrown in /home/sitename/www/wp-content/plugins/simple-custom-website-data/custom-website-data.php on line 202

    May be i need to add or enable some php or apache module/extension?

    thx in advance??

    https://wordpress.org/plugins/simple-custom-website-data/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author DannyWeeks

    (@dannyweeks)

    Hey cancrexo,

    I’m glad to hear you’ve found the plugin useful on your local server; shame about the remote server issue! I have had a look into it and it is a strange one as I haven’t come across this before but it is easily fixed. I will put a patch out tomorrow morning which will address this issue and should avoid it entirely.

    Thanks
    Danny

    Plugin Author DannyWeeks

    (@dannyweeks)

    I have released version 2.0.3 which addresses this issue! Let me know if you have any other problems!

    Danny

    Hi Danny!!
    Just updated and everything worked like a charm!!

    Very appreciated!!

    Cancrexo

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error on activation’ is closed to new replies.