Support » Plugin: qTranslate X » Error

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Gunu

    (@grafcom)

    @segapunk,

    Get error when switching plugin on

    I like some more information….

    What is the error description?

    Fatal error: Call to undefined function qtranxf_save_languages() in /var/www/html/wp-content/plugins/qtranslate-x/admin/qtx_activation_hook.php on line 50

    Plugin Author Gunu

    (@grafcom)

    @segapunk,

    which plugins you use and what theme?

    Plugin Author John Clause

    (@johnclause)

    Hi @segapunk, yes, indeed I was able to reproduce, this is a new code to handle very rare case for the fresh install, and it escaped testing. We will fix that, but that error would appear on the initial activation only, and it should work ok after you configured languages needed. Is that correct? Reading https://qtranslatexteam.wordpress.com/startup-guide/ may help.

    I am also curious, which entry it shows for you in the field “Site Language” on page “/wp-admin/options-general.php”, when qTranslate-X is off? Your language is apparently not predefined in q-X, otherwise you would not get the error. It would be good if you could send us information, which you entered on page “/wp-admin/options-general.php?page=qtranslate-x”, when you defined your language, so that we can put it in the list of predefined languages.

    Hi,

    I had the same problem:

    Fatal error: Call to undefined function qtranxf_save_languages() in /mnt/webr/b1/04/54599704/htdocs/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_activation_hook.php on line 50

    The language selected in /wp-admin/options-general.php page was Catalan. I changed it to English (US) and then the activation went correctly.

    Thanks for the information above!

    same error.

    i working with wordpress multisite.

    before 3.3 it works well.

    now, when i creating new blog with default wordpress theme and without any plugin i get this error (when i try to activate the plugin).

    any news about fix?

    Plugin Author Gunu

    (@grafcom)

    @igornn,

    would you like to try it with the latest development version?

    download it here

    Do not use install via WordPress admin!
    First unzip the new file.
    Deactivate the existing version of qTranslate in WordPress admin.
    Then with FTP delete all files in the existing qtranslate-x folder and after that copy all new files in it.
    Activate qTranslate-x again via WordPress admin.

    Hi,
    the last version fixed this error.

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error’ is closed to new replies.