Support » Plugin: Mail On Update » Error 501 on activation

  • Resolved Marcelo Pedra

    (@kent-brockman)


    Hi! I just wanted to give it a try to your plugin but this happens anytime I try to activate the plugin:

    Error 501 – Not Implemented

    GET to /staging/wp-admin/plugins.php not supported.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    FYI: the server runs PHP 5.4.35 as cgi. Apache 2.4. MySQL 5.6.
    Any ideas? Let me know if you need more info.

    https://wordpress.org/plugins/mail-on-update/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author kubi23

    (@kubi23)

    This doesnt look like a plugin issue. 501 is a server issue. Does this only occur with the mail-on-update plugin?

    Yep, I have almost 40 WP sites and multisites in that server since 2010 and this is the first time I see this error.
    Any idea? maybe the server firewall?

    No PHP errors indeed. I’ll test it in other sites, and in other servers.

    Plugin Author kubi23

    (@kubi23)

    Is it a multisite installation you are installing the plugin? When does the error exactly occur?

    Cheers,
    Sven

    I tested it on PHP 5.3: it works ok. Not received an update notification but the plugin was able to be active and work.

    But under PHP 5.4.35 is not possible to activate the plugin. It generates a 501, and 404s when you try to uninstall it. Manually deleted now.

    Both servers are equally configured.

    Not in multisite yet. I tested it in 2 standalone WP on PHP 5.3.29, and 2 other sites using PHP 5.4.35

    Plugin Author kubi23

    (@kubi23)

    Is it a multisite installation you are installing the plugin?

    As I said above: not in multisite yet. I just want to make it work in standalones first.

    Plugin Author kubi23

    (@kubi23)

    To be honest, I have no idea how to dig into this issue. I will check if there are any deprecated function which may collide with the PHP version.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error 501 on activation’ is closed to new replies.